aboutsummaryrefslogtreecommitdiff
path: root/libs/p11-kit
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-12-01 16:42:04 -0800
committerRosen Penev <rosenp@gmail.com>2019-12-01 16:58:08 -0800
commitd9c4ddc7ee42b591696bf65e7be979ade7ced56b (patch)
tree765104e678da95bc7fd5cad27d282b4eab6466b8 /libs/p11-kit
parent1d434b00e70958e22449f876f0155f5986ef39c5 (diff)
p11-kit: Fix uClibc-ng compile failure
It seems the issue was not fixed. Easiest way to fix is to pass the proper configure variable. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/p11-kit')
-rw-r--r--libs/p11-kit/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/libs/p11-kit/Makefile b/libs/p11-kit/Makefile
index 5dcbe0c9a..3fbfaab87 100644
--- a/libs/p11-kit/Makefile
+++ b/libs/p11-kit/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=p11-kit
PKG_VERSION:=0.23.18.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/p11-glue/p11-kit/releases/download/$(PKG_VERSION)
@@ -47,6 +47,9 @@ CONFIGURE_ARGS+= \
--without-libffi \
--without-systemd
+CONFIGURE_VARS += \
+ ac_cv_have_decl_program_invocation_short_name=yes
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/p11-kit-1/p11-kit/
$(CP) $(PKG_INSTALL_DIR)/usr/include/p11-kit-1/p11-kit/* $(1)/usr/include/p11-kit-1/p11-kit/