aboutsummaryrefslogtreecommitdiff
path: root/libs/opus
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-05-11 03:02:05 +0800
committerJeffery To <jeffery.to@gmail.com>2020-05-11 03:10:20 +0800
commit2d99ee3004a1b3aa099d90bff4eae627d11c53e8 (patch)
treeb28771d6b1d994e92c2e53799d1d6f905561e0b8 /libs/opus
parentb7c59c390f0b739403ae9099e1affe94d214b51d (diff)
treewide: Update ARM NEON/VFP detection
With openwrt/openwrt@8dcc1087602e2dd606e4f6e81a06aee62cfd4f4c, the ARM FPU compiler options are no longer part of CONFIG_TARGET_OPTIMIZATION. This updates various packages that look for NEON/VFP support to search CONFIG_CPU_TYPE instead. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'libs/opus')
-rw-r--r--libs/opus/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/opus/Makefile b/libs/opus/Makefile
index 689b7c0ea..1c106128f 100644
--- a/libs/opus/Makefile
+++ b/libs/opus/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=opus
PKG_VERSION:=1.3.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://archive.mozilla.org/pub/opus
@@ -47,7 +47,7 @@ ifeq ($(CONFIG_SOFT_FLOAT),y)
--enable-fixed-point
endif
-ifneq ($(findstring neon,$(CONFIG_TARGET_OPTIMIZATION)),)
+ifneq ($(findstring neon,$(CONFIG_CPU_TYPE)),)
CONFIGURE_ARGS+= \
--enable-fixed-point
endif