aboutsummaryrefslogtreecommitdiff
path: root/libs/opus/Makefile
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-03-20 11:39:20 +0200
committerTianling Shen <cnsztl@gmail.com>2024-03-22 16:09:21 +0800
commit6c3db5d603c3a9ed94ce4e15b556b6a0d1daf15f (patch)
tree65205790fb8833692e2d891672aa99827c8b0abe /libs/opus/Makefile
parent1b7cedfdc25767b80e0a903c8c916ca82cccb3d3 (diff)
opus: update to 1.5.1
- Switch to Meson build system - Update patch with Meson build fixes Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'libs/opus/Makefile')
-rw-r--r--libs/opus/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/libs/opus/Makefile b/libs/opus/Makefile
index 978198baa..da931c6db 100644
--- a/libs/opus/Makefile
+++ b/libs/opus/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=opus
-PKG_VERSION:=1.4
+PKG_VERSION:=1.5.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://downloads.xiph.org/releases/opus
-PKG_HASH:=c9b32b4253be5ae63d1ff16eea06b94b5f0f2951b7a02aceef58e3a3ce49c51f
+PKG_HASH:=b84610959b8d417b611aa12a22565e0a3732097c6389d19098d844543e340f85
PKG_MAINTAINER:=Ted Hess <thess@kitchensync.net>, Ian Leonard <antonlacon@gmail.com>
PKG_LICENSE:=BSD-3-Clause
@@ -24,6 +24,7 @@ PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/meson.mk
define Package/libopus
SECTION:=libs
@@ -38,23 +39,23 @@ define Package/libopus/description
is also intended for storage and streaming applications.
endef
-CONFIGURE_ARGS+= \
- --disable-doc \
- --disable-extra-programs
+MESON_ARGS+= \
+ -Ddocs=disabled \
+ -Dextra-programs=disabled
ifeq ($(CONFIG_SOFT_FLOAT),y)
- CONFIGURE_ARGS+= \
- --enable-fixed-point
+ MESON_ARGS+= \
+ -Dfixed-point=true
endif
ifneq ($(findstring neon,$(CONFIG_CPU_TYPE))$(findstring aarch64,$(CONFIG_ARCH)),)
- CONFIGURE_ARGS+= \
- --enable-fixed-point
+ MESON_ARGS+= \
+ -Dfixed-point=true
endif
CPU_ASM_BLACKLIST:=xscale arm926ej-s
ifneq ($(findstring $(call qstrip,$(CONFIG_CPU_TYPE)),$(CPU_ASM_BLACKLIST)),)
- CONFIGURE_ARGS+= --disable-asm
+ MESON_ARGS+= -Dasm=disabled
endif
define Build/InstallDev