aboutsummaryrefslogtreecommitdiff
path: root/libs/openldap
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2018-05-24 10:29:40 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2018-05-24 10:29:40 -0300
commitb06bac022a6436382938216817ae8ee3041690df (patch)
treee10f110dda01a5478c3c1c93eaa72bdda5a7fce8 /libs/openldap
parentd9e9b59159309449df7a7a6d4ab87980dc16eac2 (diff)
openldap: use /dev/urandom as entropy source
When cross-compiling, the configure script doesn't use /dev/urandom as entropy source, which would have been the case if we were building it natively. Instead it tries to use an EGD, which openwrt doesn't supply. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'libs/openldap')
-rw-r--r--libs/openldap/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/libs/openldap/Makefile b/libs/openldap/Makefile
index 7269cf67a..b036641d0 100644
--- a/libs/openldap/Makefile
+++ b/libs/openldap/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openldap
PKG_VERSION:=2.4.45
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
@@ -82,7 +82,8 @@ define Package/openldap-server/conffiles
/etc/openldap/slapd.conf
endef
-TARGET_CFLAGS += $(FPIC) -lpthread
+TARGET_CFLAGS += $(FPIC) -lpthread \
+ -DURANDOM_DEVICE=\\\"/dev/urandom\\\"
CONFIGURE_ARGS += \
--enable-shared \