aboutsummaryrefslogtreecommitdiff
path: root/libs/nlohmannjson
diff options
context:
space:
mode:
authorLeonid Esman <leonid.esman@gmail.com>2019-11-28 12:45:39 +0300
committerLeonid Esman <leonid.esman@gmail.com>2019-12-14 23:40:37 +0300
commitb891d6ad78d336d544d82493b647d0a52127a81a (patch)
tree55d5471dac553357bec3f6766e9495b9c07ac6db /libs/nlohmannjson
parentf0eb182472dcbf18df511828b0287f1353684525 (diff)
nlohmannjson: initial commit
JSON for Modern C++ library. Design goals: intuitive syntax, trivial integration, serious testing. https://nlohmann.github.io/json/ IPFS C++ HTTP API client library depends on this library. Signed-off-by: Leonid Esman <leonid.esman@gmail.com>
Diffstat (limited to 'libs/nlohmannjson')
-rw-r--r--libs/nlohmannjson/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/libs/nlohmannjson/Makefile b/libs/nlohmannjson/Makefile
new file mode 100644
index 000000000..200f89ad6
--- /dev/null
+++ b/libs/nlohmannjson/Makefile
@@ -0,0 +1,38 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=nlohmannjson
+PKG_VERSION:=3.7.3
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=Leonid Esman <leonid.esman@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE.MIT
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/json-$(PKG_VERSION)
+PKG_SOURCE:=json-$(PKG_VERSION).zip
+PKG_SOURCE_URL:=https://codeload.github.com/nlohmann/json/zip/v$(PKG_VERSION)?
+PKG_HASH:=e109cd4a9d1d463a62f0a81d7c6719ecd780a52fb80a22b901ed5b6fe43fb45b
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/nlohmannjson
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=JSON for Modern C++
+ URL:=https://nlohmann.github.io/json/
+endef
+
+define Package/nlohmannjson/description
+ Niels Lohmann's JSON headers-only library for modern C++
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_BUILD_DIR)/include/nlohmann $(1)/usr/include
+endef
+
+$(eval $(call BuildPackage,nlohmannjson))