aboutsummaryrefslogtreecommitdiff
path: root/libs/neon
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-14 20:53:13 -0700
committerRosen Penev <rosenp@gmail.com>2020-07-15 11:57:06 -0700
commit36f3d2892fb3d6a3d2e303efe0886566940bd2f2 (patch)
tree8faabfc916822554f665d2aef93f75f0d39f9099 /libs/neon
parente06825218f982b40adb798f90ae1abd9e56c79ae (diff)
neon: update to 0.31.2
Remove upstreamed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/neon')
-rw-r--r--libs/neon/Makefile6
-rw-r--r--libs/neon/patches/010-openssl-deprecated.patch15
2 files changed, 3 insertions, 18 deletions
diff --git a/libs/neon/Makefile b/libs/neon/Makefile
index 87b9e2d00..328eb8bcc 100644
--- a/libs/neon/Makefile
+++ b/libs/neon/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=neon
-PKG_VERSION:=0.31.1
-PKG_RELEASE:=2
+PKG_VERSION:=0.31.2
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://notroj.github.io/neon
-PKG_HASH:=c9dfcee723050df37ce18ba449d7707b78e7ab8230f3a4c59d9112e17dc2718d
+PKG_HASH:=cf1ee3ac27a215814a9c80803fcee4f0ede8466ebead40267a9bd115e16a8678
PKG_MAINTAINER:=Federico Di Marco <fededim@gmail.com>
PKG_LICENSE:=LGPL-2.1-or-later
diff --git a/libs/neon/patches/010-openssl-deprecated.patch b/libs/neon/patches/010-openssl-deprecated.patch
deleted file mode 100644
index 38f9159c5..000000000
--- a/libs/neon/patches/010-openssl-deprecated.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/src/ne_openssl.c
-+++ b/src/ne_openssl.c
-@@ -230,10 +230,10 @@ void ne_ssl_cert_validity_time(const ne_ssl_certificate *cert,
- time_t *from, time_t *until)
- {
- if (from) {
-- *from = asn1time_to_timet(X509_get_notBefore(cert->subject));
-+ *from = asn1time_to_timet(X509_get0_notBefore(cert->subject));
- }
- if (until) {
-- *until = asn1time_to_timet(X509_get_notAfter(cert->subject));
-+ *until = asn1time_to_timet(X509_get0_notAfter(cert->subject));
- }
- }
-