aboutsummaryrefslogtreecommitdiff
path: root/libs/neon/Makefile
diff options
context:
space:
mode:
authorEtienne CHAMPETIER <champetier.etienne@gmail.com>2014-09-12 19:43:08 +0200
committerEtienne CHAMPETIER <champetier.etienne@gmail.com>2014-09-12 21:16:10 +0200
commiteb07b2c0559fbe55ad7833cbb184a3843574caf4 (patch)
tree232b2e4b0f4ecd1d1ab0615be6a7d47addd73879 /libs/neon/Makefile
parent2c21f90b843437505808a0e6719d2b3364ca8382 (diff)
libs/neon: update to latest, add maintainer, add description
the package (ipk) was previously called libneon, so I keep this name instead of neon. Signed-off-by: Federico Di Marco <fededim@gmail.com> Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
Diffstat (limited to 'libs/neon/Makefile')
-rw-r--r--libs/neon/Makefile27
1 files changed, 21 insertions, 6 deletions
diff --git a/libs/neon/Makefile b/libs/neon/Makefile
index 4a95cacf8..4d3bf8cf5 100644
--- a/libs/neon/Makefile
+++ b/libs/neon/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,14 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=neon
-PKG_VERSION:=0.29.6
-PKG_RELEASE:=2
+PKG_VERSION:=0.30.0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.webdav.org/neon
-PKG_MD5SUM:=591e0c82e6979e7e615211b386b8f6bc
+PKG_MD5SUM:=fb60b3a124eeec441937a812c456fd94
-PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@@ -26,8 +25,24 @@ define Package/libneon
TITLE:=HTTP and WebDAV client library
URL:=http://www.webdav.org/neon/
DEPENDS:=+libopenssl +libexpat
+ MAINTAINER:=Federico Di Marco <fededim@gmail.com>
endef
+define Package/libneon/description
+ neon is an HTTP and WebDAV client library, with a C interface. Features:
+
+ - High-level wrappers for common HTTP and WebDAV operations (GET, MOVE, DELETE, etc)
+ - Low-level interface to the HTTP request/response engine, allowing the use of arbitrary HTTP methods, headers, etc.
+ - Authentication support including Basic and Digest support, along with GSSAPI-based Negotiate on Unix, and
+ SSPI-based Negotiate/NTLM on Win32
+ - SSL/TLS support using OpenSSL or GnuTLS; exposing an abstraction layer for verifying server certificates, handling client
+ certificates, and examining certificate properties. Smartcard-based client certificates are also supported via a
+ PKCS11 wrapper interface.
+ - Abstract interface to parsing XML using libxml2 or expat, and wrappers for simplifying handling XML HTTP response bodies
+ - WebDAV metadata support; wrappers for PROPFIND and PROPPATCH to simplify property manipulation.
+endef
+
+
TARGET_CFLAGS += $(FPIC)
TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
@@ -37,7 +52,7 @@ CONFIGURE_ARGS += \
--with-expat \
--with-ssl="openssl" \
--without-egd \
- --without-libproxy \
+ --without-libproxy
CONFIGURE_VARS += \
LDFLAGS="$$$$LDFLAGS -lcrypto -lssl"