aboutsummaryrefslogtreecommitdiff
path: root/libs/musl-fts
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2017-03-06 13:04:26 +0200
committerLucian Cristian <lucian.cristian@gmail.com>2017-03-06 13:04:26 +0200
commit2f37e5f4f9299e99afa2aaaa2c202092c1493efa (patch)
tree2fe06ed9292dc641a17b9c0600c21527019b72dd /libs/musl-fts
parent325bba709500d109ff8790d91b44f952cc075c5a (diff)
libs: add musl fts implementation
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'libs/musl-fts')
-rw-r--r--libs/musl-fts/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/libs/musl-fts/Makefile b/libs/musl-fts/Makefile
new file mode 100644
index 000000000..2b74c58a4
--- /dev/null
+++ b/libs/musl-fts/Makefile
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2017 Lucian Cristian <lucian.cristian@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# updated to work with latest source from abrasive
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=musl-fts
+PKG_VERSION:=1.2.7
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/pullmoll/musl-fts.git
+PKG_SOURCE_VERSION:=0bde52df588e8969879a2cae51c3a4774ec62472
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+
+PKG_MAINTAINER:= Lucian Cristian <lucian.cristian@gmail.com>
+
+PKG_LICENSE:=LGPL-2.1
+PKG_LICENSE_FILES:=COPYING AUTHORS
+
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=autogen.sh
+
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/$(PKG_NAME)
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=fts implementation for musl libc
+ URL:=https://github.com/pullmoll/musl-fts
+ DEPENDS:= +libpthread
+endef
+
+define Package/$(PKG_NAME)/description
+ The musl-fts package implements the fts(3) functions fts_open, fts_read, fts_children, fts_set and fts_close, which are missing in musl libc.
+endef
+
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/fts.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfts.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/musl-fts.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfts.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,$(PKG_NAME)))