aboutsummaryrefslogtreecommitdiff
path: root/libs/mtdev
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-01-30 22:51:22 -0800
committerDaniel Golle <daniel@makrotopia.org>2022-01-31 18:56:25 +0000
commite6a5bbbc8ee3b985083e9513bb2186a62476a249 (patch)
tree14af2171bc1fe497425ea26b9bb8d994d8885cf8 /libs/mtdev
parent00af0fa946ec012270596e774773b9a5c578f659 (diff)
mtdev: fix bad printf formats
Easiest to just change the type. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/mtdev')
-rw-r--r--libs/mtdev/Makefile2
-rw-r--r--libs/mtdev/patches/010-format.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/libs/mtdev/Makefile b/libs/mtdev/Makefile
index 605041027..3d49227cb 100644
--- a/libs/mtdev/Makefile
+++ b/libs/mtdev/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mtdev
PKG_VERSION:=1.1.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://bitmath.org/code/mtdev/
diff --git a/libs/mtdev/patches/010-format.patch b/libs/mtdev/patches/010-format.patch
new file mode 100644
index 000000000..c456c4b89
--- /dev/null
+++ b/libs/mtdev/patches/010-format.patch
@@ -0,0 +1,11 @@
+--- a/test/mtdev-test.c
++++ b/test/mtdev-test.c
+@@ -38,7 +38,7 @@
+ #endif
+
+ /* year-proof millisecond event time */
+-typedef uint64_t mstime_t;
++typedef unsigned long long mstime_t;
+
+ static int use_event(const struct input_event *ev)
+ {