aboutsummaryrefslogtreecommitdiff
path: root/libs/loudmouth
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2018-07-27 23:16:05 -0400
committerW. Michael Petullo <mike@flyn.org>2018-07-27 23:16:05 -0400
commitca6d16370b38e3117c1b954bb3f38ff4595db8ff (patch)
treea9bbd721b24b428d42e4f29df992db8cd8a057bd /libs/loudmouth
parent2d79ac1fa305ab6fc74fedfc3009f13ab4b4f6ab (diff)
loudmouth: fix build
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'libs/loudmouth')
-rw-r--r--libs/loudmouth/Makefile2
-rw-r--r--libs/loudmouth/patches/002-fix-comparison.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/libs/loudmouth/Makefile b/libs/loudmouth/Makefile
index e5f77cac7..3f2c60b34 100644
--- a/libs/loudmouth/Makefile
+++ b/libs/loudmouth/Makefile
@@ -31,7 +31,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/loudmouth
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+glib2 +libopenssl
+ DEPENDS:=+glib2 +libopenssl +PACKAGE_krb5-libs:krb5-libs
TITLE:=loudmouth
URL:=https://github.com/mcabber/loudmouth
endef
diff --git a/libs/loudmouth/patches/002-fix-comparison.patch b/libs/loudmouth/patches/002-fix-comparison.patch
new file mode 100644
index 000000000..7373516cb
--- /dev/null
+++ b/libs/loudmouth/patches/002-fix-comparison.patch
@@ -0,0 +1,12 @@
+diff -u --recursive loudmouth-1.5.3-vanilla/loudmouth/lm-sasl.c loudmouth-1.5.3/loudmouth/lm-sasl.c
+--- loudmouth-1.5.3-vanilla/loudmouth/lm-sasl.c 2018-07-27 22:42:03.250616281 -0400
++++ loudmouth-1.5.3/loudmouth/lm-sasl.c 2018-07-27 22:42:26.756659723 -0400
+@@ -529,7 +529,7 @@
+ }
+
+ nonce = g_hash_table_lookup (challenge, "nonce");
+- if (nonce == NULL || nonce == '\0') {
++ if (nonce == NULL || *nonce == '\0') {
+ g_log (LM_LOG_DOMAIN, LM_LOG_LEVEL_SASL,
+ "%s: server didn't provide a nonce in the challenge",
+ G_STRFUNC);