aboutsummaryrefslogtreecommitdiff
path: root/libs/loudmouth/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-18 04:39:56 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-18 04:48:07 +0100
commitdcb2407c89638b98eca547fa766f38c2179fbd8d (patch)
treea363b23158ff2c9a1d20cba77181f685369f090c /libs/loudmouth/Makefile
parent12df5439b812ce34f9f716f3e19f603ead296701 (diff)
loudmouth: fix autoconf errors
Do not override configure recipe and do not invoke upstream autogen.sh. The shipped autogen.sh attempts to call "gtkdocize" which is no guaranteed build prereq of LEDE or OpenWrt. Also add a patch to disable the processing of documentation, tests and examples as these resources rely on gtk-doc infrastructure which is not available within LEDE or OpenWrt. Example error for the bad autogen.sh invocation: ( cd .../loudmouth-1.5.3; ./autogen.sh ) ./autogen.sh: 33: ./autogen.sh: gtkdocize: not found Makefile:73: recipe for target '.../.configured_yynyyyyn' failed Example error for the lacking gtk-doc automake infrastructure: automake: error: cannot open < gtk-doc.make: No such file or directory autoreconf: .../host/bin/automake failed with exit status: 1 [...] config.status: error: cannot find input file: `docs/reference/Makefile.in' Makefile:72: recipe for target '.../.configured_yynyn' failed Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'libs/loudmouth/Makefile')
-rw-r--r--libs/loudmouth/Makefile5
1 files changed, 0 insertions, 5 deletions
diff --git a/libs/loudmouth/Makefile b/libs/loudmouth/Makefile
index 1f062093d..f8ad4df6c 100644
--- a/libs/loudmouth/Makefile
+++ b/libs/loudmouth/Makefile
@@ -43,11 +43,6 @@ endef
CONFIGURE_ARGS += \
--with-ssl=openssl
-define Build/Configure
- ( cd $(PKG_BUILD_DIR); ./autogen.sh )
- $(call Build/Configure/Default)
-endef
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/
$(CP) \