aboutsummaryrefslogtreecommitdiff
path: root/libs/log4cplus
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-10-28 17:30:16 -0700
committerRosen Penev <rosenp@gmail.com>2021-10-28 17:31:06 -0700
commita1f1303ae3ef9dbced4ce20624703edafe463c1b (patch)
tree5d3a9d339cf097789fdf4f9361ec24561697e437 /libs/log4cplus
parent53b5695ea8eb73346f7871ba1fd1d8211bb333fa (diff)
lib4cplus: update to 2.0.7
Switch to static lib. Avoids rpath hacks. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/log4cplus')
-rw-r--r--libs/log4cplus/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/libs/log4cplus/Makefile b/libs/log4cplus/Makefile
index dcdd9f3e8..ba03d9c0a 100644
--- a/libs/log4cplus/Makefile
+++ b/libs/log4cplus/Makefile
@@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=log4cplus
-PKG_VERSION:=2.0.6
+PKG_VERSION:=2.0.7
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_HASH:=73519a5e47c40cf375aa6cd28a703b01908b5dcd3f4cb4290db2fef237c8180c
+PKG_HASH:=8f74a0a5920ba044b24e2ebeb0f1e5e36d85d5c23ed48d9fe328882b16130db8
PKG_MAINTAINER:=BangLang Huang <banglang.huang@foxmail.com>, Rosy Song <rosysong@rosinson.com>
PKG_LICENSE:=BSD-2-Clause Apache-2.0
@@ -43,11 +43,12 @@ endef
OPTIONS:= \
-DLOG4CPLUS_BUILD_LOGGINGSERVER:BOOL=OFF \
-DLOG4CPLUS_BUILD_TESTING:BOOL=OFF \
+ -DLOG4CPLUS_ENABLE_DECORATED_LIBRARY_NAME:BOOL=OFF \
-DUNICODE:BOOL=OFF \
-DWITH_ICONV:BOOL=OFF
-CMAKE_HOST_OPTIONS += $(OPTIONS)
-CMAKE_OPTIONS += $(OPTIONS)
+CMAKE_HOST_OPTIONS += $(OPTIONS) -DBUILD_SHARED_LIBS=OFF
+CMAKE_OPTIONS += $(OPTIONS) -DBUILD_SHARED_LIBS=ON
TARGET_CFLAGS += -flto
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed