aboutsummaryrefslogtreecommitdiff
path: root/libs/libzdb
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2018-05-23 23:26:21 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2018-05-23 23:26:21 -0300
commit0f9a536daf02d47bca67ac3bf1ae394bd9b844be (patch)
tree26966d485e4671897676003cce307cd4156004e0 /libs/libzdb
parentd9e9b59159309449df7a7a6d4ab87980dc16eac2 (diff)
libzdb: add compatibility with openssl 1.1
This patch merely updates the detection of the ssl library. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'libs/libzdb')
-rw-r--r--libs/libzdb/Makefile2
-rw-r--r--libs/libzdb/patches/030-openssl-1.1.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/libs/libzdb/Makefile b/libs/libzdb/Makefile
index 1c172bd33..1034d041d 100644
--- a/libs/libzdb/Makefile
+++ b/libs/libzdb/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libzdb
PKG_VERSION:=3.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=GPL-3.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/libs/libzdb/patches/030-openssl-1.1.patch b/libs/libzdb/patches/030-openssl-1.1.patch
new file mode 100644
index 000000000..b4f16a1ba
--- /dev/null
+++ b/libs/libzdb/patches/030-openssl-1.1.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -141,7 +141,7 @@ AC_ARG_ENABLE([openssl],
+ else
+ openssl="true"
+ if test "x$enableval" = "xyes"; then
+- AC_CHECK_LIB([ssl], [SSL_library_init], [], [AC_MSG_ERROR([libssl not found])])
++ AC_CHECK_LIB([ssl], [SSL_CTX_new], [], [AC_MSG_ERROR([libssl not found])])
+ AC_CHECK_LIB([crypto], [SHA1_Init], [], [AC_MSG_ERROR([libcrypto not found])])
+ else
+ AC_MSG_CHECKING([for openssl in $enableval])