aboutsummaryrefslogtreecommitdiff
path: root/libs/libxml2
diff options
context:
space:
mode:
authorJames Le Cuirot <james.le-cuirot@yakara.com>2014-12-02 11:10:06 +0000
committerJames Le Cuirot <james.le-cuirot@yakara.com>2014-12-02 11:14:42 +0000
commita5409590203d66a633005e3e6a53ebe538899a4c (patch)
tree095620d581021d6c19768ed96b361a849e335672 /libs/libxml2
parent38befcd838e3c8bc6953dd2dd30126d8a4186f56 (diff)
libxml2: Fix zlib detection the right way
The previous fix (#557) forced -lz into LDFLAGS instead of fixing the real issue where configure was failing to detect zlib in the first place. This was happening because it was looking in /lib, resulting in conflicts with the host libraries. Signed-off-by: James Le Cuirot <james.le-cuirot@yakara.com>
Diffstat (limited to 'libs/libxml2')
-rw-r--r--libs/libxml2/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/libs/libxml2/Makefile b/libs/libxml2/Makefile
index b22761f7d..05eb83869 100644
--- a/libs/libxml2/Makefile
+++ b/libs/libxml2/Makefile
@@ -42,7 +42,6 @@ define Package/libxml2/description
endef
TARGET_CFLAGS += $(FPIC)
-TARGET_LDFLAGS += -lz
CONFIGURE_ARGS += \
--enable-shared \
@@ -73,7 +72,7 @@ CONFIGURE_ARGS += \
--with-xinclude \
--with-xpath \
--with-xptr \
- --with-zlib \
+ --with-zlib=$(STAGING_DIR)/usr \
--without-lzma
HOST_CONFIGURE_ARGS += \