aboutsummaryrefslogtreecommitdiff
path: root/libs/libx264
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2016-08-19 17:48:25 -0400
committerTed Hess <thess@kitschensync.net>2016-08-19 17:48:33 -0400
commitf628fa9f831df393ef4c485dc8ade906499b83ba (patch)
treee16bd3725a9c39b56999cf6a6eed16b898407d82 /libs/libx264
parent6c91a16c6dfb1605ca356aa7665739d9e098af27 (diff)
libx264: Fix build errors on x86 targets due to missing ASM features (yasm)
minor cleanup of CFLAGS, remove COPTS warnings yasm needs to be added to x86 toolchain (LEDE updated: https://github.com/lede-project/source/commit/c08651226f5645204f91f79d247801033f6015d1) Signed-off-by: Daniel Golle daniel@makrotopia.org Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'libs/libx264')
-rw-r--r--libs/libx264/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/libs/libx264/Makefile b/libs/libx264/Makefile
index b99e6bd74..3803808d7 100644
--- a/libs/libx264/Makefile
+++ b/libs/libx264/Makefile
@@ -24,9 +24,14 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
-TARGET_CFLAGS:=-Wno-maybe-uninitialized -Wshadow -Wall -std=gnu99 -fPIC -O3 -ffast-math -I.
+TARGET_CFLAGS+=-std=gnu99 -fPIC -O3 -ffast-math -I.
MAKE_FLAGS+= LD="$(TARGET_CC) -o"
+ifneq ($(CONFIG_TARGET_x86),)
+ CONFIGURE_VARS+= AS=yasm
+ MAKE_FLAGS+= AS=yasm
+endif
+
CONFIGURE_ARGS += \
--enable-shared \
--enable-pic \
@@ -40,7 +45,7 @@ define Package/libx264
SECTION:=libs
CATEGORY:=Libraries
TITLE:=H264/AVC free codec library.
- DEPENDS:=@BUILD_PATENTED
+ DEPENDS:=@BUILD_PATENTED @!TARGET_x86||YASM
URL:=http://www.videolan.org/developers/x264.html
endef