aboutsummaryrefslogtreecommitdiff
path: root/libs/libx264/Makefile
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2020-03-02 23:59:10 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2020-03-14 03:32:00 +0100
commitfaac2352e2d3f14de8dfd69f1801e6561ccb156c (patch)
tree4f0278faef93e7cbc315da04a73ee07ffa3c75a6 /libs/libx264/Makefile
parent09d0928cc25205633d176b80c1ee87bb21e76ccf (diff)
x264: add CONFIGURE_VARS and MAKE_FLAGS when NASM is not selected
- Remove dot in TITLE - Use HTTPS in URL Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'libs/libx264/Makefile')
-rw-r--r--libs/libx264/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/libs/libx264/Makefile b/libs/libx264/Makefile
index 6bbcf4f88..44c53b098 100644
--- a/libs/libx264/Makefile
+++ b/libs/libx264/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=x264
PKG_VERSION:=snapshot-20190324-2245
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.videolan.org/x264/snapshots/
@@ -39,6 +39,8 @@ ifneq ($(findstring cortex-a,$(CPU_TYPE)),)
MAKE_FLAGS+= AS=nasm
endif
else
+ CONFIGURE_VARS+= AS=
+ MAKE_FLAGS+= AS=
CONFIGURE_ARGS += --disable-asm
endif
endif
@@ -56,9 +58,9 @@ CONFIGURE_ARGS += \
define Package/libx264
SECTION:=libs
CATEGORY:=Libraries
- TITLE:=H264/AVC free codec library.
+ TITLE:=H264/AVC free codec library
DEPENDS:=+libpthread @BUILD_PATENTED
- URL:=http://www.videolan.org/developers/x264.html
+ URL:=https://www.videolan.org/developers/x264.html
endef
define Package/libx264/description