aboutsummaryrefslogtreecommitdiff
path: root/libs/libx264/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-09-23 00:23:24 +0200
committerDaniel Golle <daniel@makrotopia.org>2016-09-23 00:31:23 +0200
commitab010288daf751df2fe2e26862546f0dd6effe72 (patch)
tree999ef260c33ecd821d3951f11c93bd215190f1dc /libs/libx264/Makefile
parent64c6b8b7354dacbd3130f2a60d02adafd3ff6ca4 (diff)
libx264: fix build on soft-float targets
--disable-asm isn't enough to disable building assembly code on ARM. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'libs/libx264/Makefile')
-rw-r--r--libs/libx264/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/libs/libx264/Makefile b/libs/libx264/Makefile
index 4dc9fec36..7054a4071 100644
--- a/libs/libx264/Makefile
+++ b/libs/libx264/Makefile
@@ -38,15 +38,17 @@ else
endif
endif
+ifneq ($(CONFIG_SOFT_FLOAT),)
+CONFIGURE_VARS+= AS=
+MAKE_FLAGS+= AS=
+CONFIGURE_ARGS += --disable-asm
+endif
+
CONFIGURE_ARGS += \
--enable-shared \
--enable-pic \
--disable-cli
-ifeq ($(CONFIG_SOFT_FLOAT),y)
-CONFIGURE_ARGS += --disable-asm
-endif
-
define Package/libx264
SECTION:=libs
CATEGORY:=Libraries