aboutsummaryrefslogtreecommitdiff
path: root/libs/libx264/Makefile
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2016-11-23 12:54:46 -0500
committerTed Hess <thess@kitschensync.net>2016-12-08 15:21:57 -0500
commita41be403e62da1b2bd000456c9182935295603cd (patch)
tree136318c2b41e02607e94271c21ef52b68c172084 /libs/libx264/Makefile
parent9637d4d02e7cf8724cbe2ad30cb9668f095e8d64 (diff)
libx264: Add AMD Geode and i486 to ASM blacklist, fix CPU type test
Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'libs/libx264/Makefile')
-rw-r--r--libs/libx264/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/libs/libx264/Makefile b/libs/libx264/Makefile
index 000a4d683..dbb7543b8 100644
--- a/libs/libx264/Makefile
+++ b/libs/libx264/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=x264
PKG_VERSION:=snapshot-20160815-2245-stable
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.videolan.org/x264/snapshots/
@@ -28,8 +28,14 @@ TARGET_CFLAGS+=-std=gnu99 -fPIC -O3 -ffast-math -I.
MAKE_FLAGS+= LD="$(TARGET_CC) -o"
# ARM ASM depends on ARM1156 or later, blacklist earlier or incompatible cores
-CPU_ASM_BLACKLIST:=arm920t arm926ej-s arm1136j-s arm1176jzf-s fa526 mpcore xscale
+# AMD Geode LX and i486 do not have SSE
+CPU_ASM_BLACKLIST:=geode i486 arm920t arm926ej-s arm1136j-s arm1176jzf-s fa526 mpcore xscale
+ifneq ($(CONFIG_SOFT_FLOAT)$(findstring $(call qstrip,$(CONFIG_CPU_TYPE)),$(CPU_ASM_BLACKLIST)),)
+ CONFIGURE_VARS+= AS=
+ MAKE_FLAGS+= AS=
+ CONFIGURE_ARGS += --disable-asm
+else
ifneq ($(CONFIG_TARGET_x86),)
ifeq ($(CONFIG_YASM),y)
CONFIGURE_VARS+= AS=yasm
@@ -40,11 +46,6 @@ else
CONFIGURE_ARGS += --disable-asm
endif
endif
-
-ifneq ($(CONFIG_SOFT_FLOAT)$(findstring $(CONFIG_CPU_TYPE),$(CPU_ASM_BLACKLIST)),)
-CONFIGURE_VARS+= AS=
-MAKE_FLAGS+= AS=
-CONFIGURE_ARGS += --disable-asm
endif
CONFIGURE_ARGS += \