aboutsummaryrefslogtreecommitdiff
path: root/libs/libx264/Makefile
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2019-04-06 20:35:33 +0000
committerDaniel Engberg <daniel.engberg.lists@pyret.net>2019-05-06 09:05:22 +0000
commit45c8dcab7944bbe5d59432f0a6b773d2109d34ca (patch)
tree2d8b29cfeda98e5a113b4eebd2e0080be993e8a2 /libs/libx264/Makefile
parent15eabe4844138635edde06ec38251cb9f58d552c (diff)
libs/libx264: Update to 20190324 and rework Makefile
* Update (lib)x264 to 20190324 * Stop using GNU Autotools and use libx264's own configuration facility * Drop hardcoded CFLAGS, x264 will handle those fine on its own This will override toolchain optimizaion and set -O3 irregardless of setting. * Rework LTO and ASM optmization selection to make it more compact and readable. This drops optimization for x86 32-bit which is being deprecated in favour of x86_64 in general and the very few systems still in use that doesn't support 64-bit are too slow to be usable anyway. * Import patches to fix compilation on ARM and x86 (32-bit) from OpenEmbedded * Minor style fixes to Makefile Source: http://cgit.openembedded.org/openembedded-core/tree/meta/recipes-multimedia/x264/x264 Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'libs/libx264/Makefile')
-rw-r--r--libs/libx264/Makefile46
1 files changed, 20 insertions, 26 deletions
diff --git a/libs/libx264/Makefile b/libs/libx264/Makefile
index 480359c1e..6bbcf4f88 100644
--- a/libs/libx264/Makefile
+++ b/libs/libx264/Makefile
@@ -8,55 +8,49 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=x264
-PKG_VERSION:=snapshot-20181006-2245
+PKG_VERSION:=snapshot-20190324-2245
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.videolan.org/x264/snapshots/
PKG_MAINTAINER:=Adrian Panella <ianchi74@outlook.com>
-PKG_HASH:=eae60e969958c0759554d5e338dea9b91f1f1fe85d9523c152c2259d8546f469
+PKG_HASH:=68010057edaadffc7593933d13084e8d32e041c42b17c089513d88c917f2ad54
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
-PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
-TARGET_CFLAGS:=$(filter-out -O%,$(TARGET_CFLAGS)) -std=gnu99 -fPIC -O3 -ffast-math -I.
-MAKE_FLAGS+= LD="$(TARGET_CC) -o"
+TARGET_CFLAGS:=$(filter-out -O%,$(TARGET_CFLAGS))
+MAKE_FLAGS:=$(filter-out LD=%,$(MAKE_FLAGS)) LD="$(TARGET_CC) -o"
-# ARM ASM depends on ARM1156 or later, blacklist earlier or incompatible cores
-# AMD Geode LX and i486 do not have SSE
-CPU_ASM_BLACKLIST:=geode i486 arm920t arm926ej-s arm1136j-s arm1176jzf-s fa526 mpcore xscale \
- 464fp mips32 24kc 34kc 74kc octeon mips64
+# Instead of blacklisting a boatload of platforms just enable
+# optimization where it makes sense (matters) ie ARMv7+ and x86_64
-ifneq ($(CONFIG_SOFT_FLOAT)$(findstring $(call qstrip,$(CONFIG_CPU_TYPE)),$(CPU_ASM_BLACKLIST)),)
- CONFIGURE_VARS+= AS=
- MAKE_FLAGS+= AS=
- CONFIGURE_ARGS += --disable-asm
-else
+ifneq ($(findstring cortex-a,$(CPU_TYPE)),)
CONFIGURE_ARGS += --enable-lto
-ifneq ($(CONFIG_TARGET_x86),)
-ifeq ($(CONFIG_NASM),y)
- CONFIGURE_VARS+= AS=nasm
- MAKE_FLAGS+= AS=nasm
-else
- CONFIGURE_VARS+= AS=
- MAKE_FLAGS+= AS=
- CONFIGURE_ARGS += --disable-asm
-endif
-endif
+ else
+ ifneq ($(CONFIG_TARGET_x86_64),)
+ CONFIGURE_ARGS += --enable-lto
+ ifeq ($(CONFIG_NASM),y)
+ CONFIGURE_VARS+= AS=nasm
+ MAKE_FLAGS+= AS=nasm
+ endif
+ else
+ CONFIGURE_ARGS += --disable-asm
+ endif
endif
CONFIGURE_ARGS += \
+ --disable-cli \
--enable-shared \
+ --disable-opencl \
--enable-pic \
- --enable-strip \
- --disable-cli \
--disable-avs \
--disable-ffms \
+ --disable-gpac \
--disable-lsmash
define Package/libx264