aboutsummaryrefslogtreecommitdiff
path: root/libs/libx264/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-04-01 17:27:09 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-04-01 17:52:34 -0700
commit39b2c6f2f5b5d4400a06df48e907d66163a9a1d3 (patch)
treeb6e35d845fafd124dd5a82ebeb0f09ccefc07538 /libs/libx264/Makefile
parent0c432f890220053330cdaf74876c6d652bfb3c11 (diff)
libx264: Blacklist all MIPS CPUs for assembly optimizations
None of the CPUs supported in OpenWrt/LEDE are MSA capable (requires MIPS32r5/r6 for that) which would lead to this error during configure: You specified a pre-MSA CPU in your CFLAGS. If you really want to run on such a CPU, configure with --disable-asm. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'libs/libx264/Makefile')
-rw-r--r--libs/libx264/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/libs/libx264/Makefile b/libs/libx264/Makefile
index dbb7543b8..8aebb85f3 100644
--- a/libs/libx264/Makefile
+++ b/libs/libx264/Makefile
@@ -29,7 +29,8 @@ MAKE_FLAGS+= LD="$(TARGET_CC) -o"
# ARM ASM depends on ARM1156 or later, blacklist earlier or incompatible cores
# AMD Geode LX and i486 do not have SSE
-CPU_ASM_BLACKLIST:=geode i486 arm920t arm926ej-s arm1136j-s arm1176jzf-s fa526 mpcore xscale
+CPU_ASM_BLACKLIST:=geode i486 arm920t arm926ej-s arm1136j-s arm1176jzf-s fa526 mpcore xscale \
+ mips32 24kc 34kc 74kc octeon mips64
ifneq ($(CONFIG_SOFT_FLOAT)$(findstring $(call qstrip,$(CONFIG_CPU_TYPE)),$(CPU_ASM_BLACKLIST)),)
CONFIGURE_VARS+= AS=