aboutsummaryrefslogtreecommitdiff
path: root/libs/libx264/Makefile
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-10 10:39:53 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-10 14:57:48 -0800
commit0bdec78a8b0cf81e3c106e44c0f527f2e4b6eefe (patch)
treeea1a6e60f1bf4ca674da99fc3b9096228c898c74 /libs/libx264/Makefile
parent3fbfef7081f16c1a2e8c6448179f95e54644a8e1 (diff)
libx264: update to 2024-01-13 revision
- Fix CPU type detection to enable asm on ARM - Refresh patches Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'libs/libx264/Makefile')
-rw-r--r--libs/libx264/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/libs/libx264/Makefile b/libs/libx264/Makefile
index 523e9f504..337c6e749 100644
--- a/libs/libx264/Makefile
+++ b/libs/libx264/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=x264
-PKG_VERSION:=2020-10-26
+PKG_VERSION:=2024-01-13
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://code.videolan.org/videolan/x264.git
-PKG_SOURCE_VERSION:=4121277b40a667665d4eea1726aefdc55d12d110
-PKG_MIRROR_HASH:=4b4955e8f92d0c4afecbced2cc6414a123085f7472d198b3eeddaa9490b84f60
+PKG_SOURCE_VERSION:=4815ccadb1890572f2bf8b9d9553d56f6c9122ad
+PKG_MIRROR_HASH:=6a8179183bdd88f2d7032342c23670e66571724ad774f96a6abac19f8eb7aad4
PKG_MAINTAINER:=Adrian Panella <ianchi74@outlook.com>
PKG_LICENSE:=GPL-2.0-or-later
@@ -31,16 +31,16 @@ MAKE_FLAGS:=$(filter-out LD=%,$(MAKE_FLAGS)) LD="$(TARGET_CC) -o"
# Instead of blacklisting a boatload of platforms just enable
# optimization where it makes sense (matters) ie ARMv7+ and x86_64
-ifneq ($(findstring cortex-a,$(CPU_TYPE)),)
+ifneq ($(findstring cortex-a,$(CONFIG_CPU_TYPE)),)
CONFIGURE_ARGS += --enable-lto
- else
+else
ifneq ($(CONFIG_TARGET_x86_64),)
CONFIGURE_ARGS += --enable-lto
ifeq ($(CONFIG_NASM),y)
CONFIGURE_VARS+= AS=nasm
MAKE_FLAGS+= AS=nasm
endif
- else
+ else
CONFIGURE_VARS+= AS=
MAKE_FLAGS+= AS=
CONFIGURE_ARGS += --disable-asm