aboutsummaryrefslogtreecommitdiff
path: root/libs/libwebsockets
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-08 15:44:06 -0800
committerKarl Palsson <karlp@etactica.com>2018-11-09 12:25:58 +0000
commite54ecea1b018411f4a2120a59b975623c674d427 (patch)
treeb7f0be929063786af7010995cdb647daedd998aa /libs/libwebsockets
parentae658a0c4a1e56ecb5ddb773fd62883165e4eb2b (diff)
libwebsockets: Fix build without deprecated OpenSSL APIs
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libwebsockets')
-rw-r--r--libs/libwebsockets/Makefile2
-rw-r--r--libs/libwebsockets/patches/010-openssl-deprecated.patch11
-rw-r--r--libs/libwebsockets/patches/020-fix-travis.patch2
3 files changed, 13 insertions, 2 deletions
diff --git a/libs/libwebsockets/Makefile b/libs/libwebsockets/Makefile
index 26dc23f54..b9fe6dc90 100644
--- a/libs/libwebsockets/Makefile
+++ b/libs/libwebsockets/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libwebsockets
PKG_VERSION:=3.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
diff --git a/libs/libwebsockets/patches/010-openssl-deprecated.patch b/libs/libwebsockets/patches/010-openssl-deprecated.patch
new file mode 100644
index 000000000..6d43ece42
--- /dev/null
+++ b/libs/libwebsockets/patches/010-openssl-deprecated.patch
@@ -0,0 +1,11 @@
+--- a/lib/tls/private.h
++++ b/lib/tls/private.h
+@@ -64,6 +64,8 @@
+ #include <openssl/err.h>
+ #include <openssl/md5.h>
+ #include <openssl/sha.h>
++ #include <openssl/rsa.h>
++ #include <openssl/bn.h>
+ #ifdef LWS_HAVE_OPENSSL_ECDH_H
+ #include <openssl/ecdh.h>
+ #endif
diff --git a/libs/libwebsockets/patches/020-fix-travis.patch b/libs/libwebsockets/patches/020-fix-travis.patch
index b6e287575..9631e6e1e 100644
--- a/libs/libwebsockets/patches/020-fix-travis.patch
+++ b/libs/libwebsockets/patches/020-fix-travis.patch
@@ -2,7 +2,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
index b260969..ece281d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1050,9 +1050,9 @@ if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX OR (CMAKE_C_COMPILER_ID
+@@ -1055,9 +1055,9 @@ if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX OR (CMAKE_C_COMPILER_ID
endif()
if (UNIX AND NOT LWS_WITH_ESP32)