aboutsummaryrefslogtreecommitdiff
path: root/libs/libwebsockets
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2022-12-26 18:31:39 +0100
committerJohn Crispin <john@phrozen.org>2023-01-03 20:31:31 +0100
commitdf13b03e506ec8036a4a1558ff8925187a94e464 (patch)
treeec52b54720856fca37e5af77330c1debb35a6b07 /libs/libwebsockets
parentce0679b61a5927ffdbc8a1505ce52756c6c394d4 (diff)
libwebsockets: fix uloop support
The commit adding uloop support failed to actually install the .so and add the correct dependencies. [2022/12/26 18:19:38:1835] E: lws_create_context: failed to load evlib_uloop Fixes: 1557ac367a ("libwebsockets: enable built in uloop support") Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'libs/libwebsockets')
-rw-r--r--libs/libwebsockets/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/libwebsockets/Makefile b/libs/libwebsockets/Makefile
index 2920cb039..bb54b6655 100644
--- a/libs/libwebsockets/Makefile
+++ b/libs/libwebsockets/Makefile
@@ -45,7 +45,7 @@ define Package/libwebsockets/Default
SECTION:=libs
CATEGORY:=Libraries
TITLE:=libwebsockets
- DEPENDS:=+zlib +libcap
+ DEPENDS:=+zlib +libcap +libubox
URL:=https://libwebsockets.org
MAINTAINER:=Karl Palsson <karlp@etactica.com>
endef
@@ -97,7 +97,7 @@ endif
define Package/libwebsockets/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libwebsockets.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libwebsockets*.so* $(1)/usr/lib/
endef
Package/libwebsockets-mbedtls/install = $(Package/libwebsockets/install)