aboutsummaryrefslogtreecommitdiff
path: root/libs/libwebsockets
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2022-10-25 07:52:15 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2022-10-25 07:57:23 +0200
commit77e682a11c53f4dcd0e76bdea5ee82de77eaacfe (patch)
tree0960125e5bb8382f7ad210a0b5aea5d944cdbdd5 /libs/libwebsockets
parent14f151ac9c075ec6b634b322535154342ac9efa7 (diff)
libwebsockets: full variant provides OpenSSL
For some time, it is not possible to install ttyd and mosquitto-ssl at the same time, so let's solve it that libwebsockets-full provides libwebsockets-openssl. This allows to install ttyd and mosquitto at the same time. Also, we need to add conflict, because we should not have installed libwebsockets-openssl and libwebsockets-full at the same time as they provides the same files. Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'libs/libwebsockets')
-rw-r--r--libs/libwebsockets/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/libs/libwebsockets/Makefile b/libs/libwebsockets/Makefile
index 22eb9aa76..49a4381f7 100644
--- a/libs/libwebsockets/Makefile
+++ b/libs/libwebsockets/Makefile
@@ -56,6 +56,7 @@ define Package/libwebsockets-openssl
TITLE += (OpenSSL)
DEPENDS += +libopenssl
VARIANT:=openssl
+ CONFLICTS:=libwebsockets-full
endef
define Package/libwebsockets-mbedtls
@@ -70,6 +71,7 @@ define Package/libwebsockets-full
TITLE += (Full - OpenSSL, libuv, plugins, CGI)
DEPENDS += +libopenssl +libuv
VARIANT:=full
+ PROVIDES:=libwebsockets-openssl
endef
ifeq ($(BUILD_VARIANT),openssl)