aboutsummaryrefslogtreecommitdiff
path: root/libs/libwebsockets
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2020-01-08 16:17:33 +1100
committerMathew McBride <matt@traverse.com.au>2020-01-08 16:41:34 +1100
commit19c284e05d293fb804559ab8b012950c65496249 (patch)
tree1fe074d91577d51a78b968adf1747623432650a9 /libs/libwebsockets
parentd0dc891c1416cbc9ef3407a295300e08b5671608 (diff)
libwebsockets: enable unix socket support in the full build
This functionality can be used by downstream applications such as ttyd to present their HTTP service as a unix domain socket rather than a TCP server. Signed-off-by: Mathew McBride <matt@traverse.com.au>
Diffstat (limited to 'libs/libwebsockets')
-rw-r--r--libs/libwebsockets/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/libs/libwebsockets/Makefile b/libs/libwebsockets/Makefile
index 7a180e3a3..b71759b04 100644
--- a/libs/libwebsockets/Makefile
+++ b/libs/libwebsockets/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libwebsockets
PKG_VERSION:=3.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -86,6 +86,7 @@ ifeq ($(BUILD_VARIANT),full)
CMAKE_OPTIONS += -DLWS_WITH_SERVER_STATUS=ON
CMAKE_OPTIONS += -DLWS_WITH_ACCESS_LOG=ON
CMAKE_OPTIONS += -DLWS_WITH_CGI=ON
+ CMAKE_OPTIONS += -DLWS_UNIX_SOCK=ON
endif
define Package/libwebsockets/install