aboutsummaryrefslogtreecommitdiff
path: root/libs/libwebsockets
diff options
context:
space:
mode:
authorKarl Palsson <karlp@etactica.com>2018-12-10 14:53:15 +0000
committerKarl Palsson <karlp@etactica.com>2018-12-10 15:33:50 +0000
commit05ec8631543314409c734cd8ed992d640c18e619 (patch)
treefeec791ec971faf9c5983ffb42d981fc794ae40a /libs/libwebsockets
parent509691b4a7794696a93d23c384875d0385c393e3 (diff)
libwebsockets: bump to 3.1.0
Drops an openssl deprecation patch applied upstream. Changes since 3.0.0, the following list of websocket related features: * gzip+brotli compression in the webserver * threadpools * string tokenizers * http reverse proxies * managed disk cache Full changes at https://libwebsockets.org/git/libwebsockets/tree/changelog?id=89eedcaa94e1c8a97ea3af10642fd224bcea068f#n4 Tested on ath79, and classic usage of libwebsockets to provide websockets support to a C application. Signed-off-by: Karl Palsson <karlp@etactica.com>
Diffstat (limited to 'libs/libwebsockets')
-rw-r--r--libs/libwebsockets/Makefile6
-rw-r--r--libs/libwebsockets/patches/010-openssl-deprecated.patch11
-rw-r--r--libs/libwebsockets/patches/020-fix-travis.patch8
3 files changed, 6 insertions, 19 deletions
diff --git a/libs/libwebsockets/Makefile b/libs/libwebsockets/Makefile
index b9fe6dc90..50fc1d5e8 100644
--- a/libs/libwebsockets/Makefile
+++ b/libs/libwebsockets/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libwebsockets
-PKG_VERSION:=3.0.1
-PKG_RELEASE:=2
+PKG_VERSION:=3.1.0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=https://codeload.github.com/warmcat/libwebsockets/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=cb0cdd8d0954fcfd97a689077568f286cdbb44111883e0a85d29860449c47cbf
+PKG_HASH:=db948be74c78fc13f1f1a55e76707d7baae3a1c8f62b625f639e8f2736298324
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
diff --git a/libs/libwebsockets/patches/010-openssl-deprecated.patch b/libs/libwebsockets/patches/010-openssl-deprecated.patch
deleted file mode 100644
index 6d43ece42..000000000
--- a/libs/libwebsockets/patches/010-openssl-deprecated.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/lib/tls/private.h
-+++ b/lib/tls/private.h
-@@ -64,6 +64,8 @@
- #include <openssl/err.h>
- #include <openssl/md5.h>
- #include <openssl/sha.h>
-+ #include <openssl/rsa.h>
-+ #include <openssl/bn.h>
- #ifdef LWS_HAVE_OPENSSL_ECDH_H
- #include <openssl/ecdh.h>
- #endif
diff --git a/libs/libwebsockets/patches/020-fix-travis.patch b/libs/libwebsockets/patches/020-fix-travis.patch
index 9631e6e1e..85b165f75 100644
--- a/libs/libwebsockets/patches/020-fix-travis.patch
+++ b/libs/libwebsockets/patches/020-fix-travis.patch
@@ -1,13 +1,11 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b260969..ece281d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1055,9 +1055,9 @@ if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX OR (CMAKE_C_COMPILER_ID
+@@ -1233,9 +1233,9 @@ if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COM
endif()
if (UNIX AND NOT LWS_WITH_ESP32)
-- set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized -Werror ${VISIBILITY_FLAG} -Wundef ${GCOV_FLAGS} ${CMAKE_C_FLAGS}" )
-+ set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized ${VISIBILITY_FLAG} -Wundef ${GCOV_FLAGS} ${CMAKE_C_FLAGS}" )
+- set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized -Werror ${VISIBILITY_FLAG} -Wundef ${GCOV_FLAGS} ${CMAKE_C_FLAGS} ${ASAN_FLAGS}" )
++ set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized ${VISIBILITY_FLAG} -Wundef ${GCOV_FLAGS} ${CMAKE_C_FLAGS} ${ASAN_FLAGS}" )
else()
- set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized -Werror ${VISIBILITY_FLAG} ${GCOV_FLAGS} ${CMAKE_C_FLAGS}" )
+ set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized ${VISIBILITY_FLAG} ${GCOV_FLAGS} ${CMAKE_C_FLAGS}" )