aboutsummaryrefslogtreecommitdiff
path: root/libs/libvpx
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2019-04-29 15:05:18 -0300
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>2019-04-29 15:05:18 -0300
commite1a2057f64c94fc85c0b4ee20572423365ab0814 (patch)
tree75c1c22fe5fe0ef2aa29409e42cd3872da1b108f /libs/libvpx
parent62eebff668085190d52a19efdfd3f88dd1d3b6a1 (diff)
libvpx: cleanup configure/make vars
Instead of redefining LD (and duplicating it), it is better to unset the existing value first. Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'libs/libvpx')
-rw-r--r--libs/libvpx/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/libs/libvpx/Makefile b/libs/libvpx/Makefile
index d43a5ca77..81ad4cd36 100644
--- a/libs/libvpx/Makefile
+++ b/libs/libvpx/Makefile
@@ -62,12 +62,9 @@ endif
# libvpx expects gcc as linker but uses $LD if provided
# However, OpenWRT defines LD as *-uclibc-ld and not *-gcc
-CONFIGURE_VARS += \
- CROSS=$(GNU_TARGET_NAME) \
- LD="$(TARGET_CC)" \
-
-MAKE_FLAGS += \
- LD="$(TARGET_CC)" \
+CONFIGURE_VARS := $(filter-out LD=%,$(CONFIGURE_VARS)) LD="$(TARGET_CC)" \
+ CROSS=$(GNU_TARGET_NAME)
+MAKE_FLAGS := $(filter-out LD=%,$(MAKE_FLAGS)) LD="$(TARGET_CC)"
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/vpx/