aboutsummaryrefslogtreecommitdiff
path: root/libs/libvorbis
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2014-07-16 12:31:58 -0400
committerTed Hess <thess@kitschensync.net>2014-07-16 12:31:58 -0400
commit448921a9437816d5f59e4124ecbe57fa9732c9b3 (patch)
tree3b2d6b366a78571814a6116a22cba1999094165b /libs/libvorbis
parent64933e52782888f2cb1e5f8863ad5ba7ac807eba (diff)
Import libvorbis from oldpackages
Diffstat (limited to 'libs/libvorbis')
-rw-r--r--libs/libvorbis/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/libs/libvorbis/Makefile b/libs/libvorbis/Makefile
new file mode 100644
index 000000000..961c86e30
--- /dev/null
+++ b/libs/libvorbis/Makefile
@@ -0,0 +1,64 @@
+#
+# Copyright (C) 2008-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libvorbis
+PKG_VERSION:=1.3.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/vorbis/
+PKG_MD5SUM:=71b649d3e08e63ece16649df906ce8b9
+
+PKG_LICENSE:=BSD-3c
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libvorbis
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=libvorbis
+ URL:=http://xiph.org/vorbis/
+ DEPENDS:=+libogg
+endef
+
+define Package/libvorbis/description
+Vorbis is a general purpose audio and music encoding format
+contemporary to MPEG-4's AAC and TwinVQ, the next generation beyond
+MPEG audio layer 3. Unlike the MPEG sponsored formats (and other
+proprietary formats such as RealAudio G2 and Windows' flavor of the
+month), the Vorbis CODEC specification belongs to the public domain.
+All the technical details are published and documented, and any
+software entity may make full use of the format without license
+fee, royalty or patent concerns.
+endef
+
+CONFIGURE_ARGS+= \
+ --disable-oggtest \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/vorbis/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/vorbis/* $(1)/usr/include/vorbis/
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+ $(INSTALL_DIR) $(1)/usr/share/aclocal/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
+endef
+
+define Package/libvorbis/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libvorbis))