aboutsummaryrefslogtreecommitdiff
path: root/libs/libv4l
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-03-28 17:33:15 -0700
committerRosen Penev <rosenp@gmail.com>2020-03-28 20:45:03 -0700
commitffb7da67a3e5858733031dc1b7012fafeb06515c (patch)
tree3f276ae7057742f6f041353d1b013af200a8655b /libs/libv4l
parente06d851a42babc615709af9da52f998c9dcf37d4 (diff)
libv4l: fix compilation with newer musl
This is using the input_event struct directly, instead of using the proper defines. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libv4l')
-rw-r--r--libs/libv4l/Makefile2
-rw-r--r--libs/libv4l/patches/040-musl.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/libs/libv4l/Makefile b/libs/libv4l/Makefile
index a58b8ff01..21fc5b9c2 100644
--- a/libs/libv4l/Makefile
+++ b/libs/libv4l/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=v4l-utils
PKG_VERSION:=1.16.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.linuxtv.org/downloads/v4l-utils
diff --git a/libs/libv4l/patches/040-musl.patch b/libs/libv4l/patches/040-musl.patch
new file mode 100644
index 000000000..79dc5d212
--- /dev/null
+++ b/libs/libv4l/patches/040-musl.patch
@@ -0,0 +1,11 @@
+--- a/utils/keytable/keytable.c
++++ b/utils/keytable/keytable.c
+@@ -1686,7 +1686,7 @@ static void test_event(struct rc_device *rc_dev, int fd)
+
+ for (i = 0; i < rd / sizeof(struct input_event); i++) {
+ printf(_("%ld.%06ld: event type %s(0x%02x)"),
+- ev[i].time.tv_sec, ev[i].time.tv_usec,
++ ev[i].input_event_sec, ev[i].input_event_usec,
+ get_event_name(events_type, ev[i].type), ev[i].type);
+
+ switch (ev[i].type) {