aboutsummaryrefslogtreecommitdiff
path: root/libs/libv4l
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-02-20 19:51:36 -0800
committerRosen Penev <rosenp@gmail.com>2021-02-20 20:03:55 -0800
commitb945b0790f8ababf8c36b9327d8d37f2ff90675b (patch)
tree1a7d0aad461cd6f06c73c54dc0bee28410e25cec /libs/libv4l
parent937a733854f32ee2d05b162909363464814efba7 (diff)
libv4l: fix glibc compilation
There was a typo in the linker flags. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libv4l')
-rw-r--r--libs/libv4l/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/libv4l/Makefile b/libs/libv4l/Makefile
index 9755f820d..4f11a0152 100644
--- a/libs/libv4l/Makefile
+++ b/libs/libv4l/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=v4l-utils
PKG_VERSION:=1.20.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.linuxtv.org/downloads/v4l-utils
@@ -78,7 +78,7 @@ endef
TARGET_CFLAGS += -flto
TARGET_CXXFLAGS += -std=c++11
TARGET_LDFLAGS += \
- $(if $(CONFIG_LIBC_USE_GLIBC),,-largp) \
+ $(if $(CONFIG_USE_GLIBC),,-largp) \
-Wl,--gc-sections,--as-needed
CONFIGURE_ARGS+= \