aboutsummaryrefslogtreecommitdiff
path: root/libs/libv4l
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-26 16:14:20 -0700
committerRosen Penev <rosenp@gmail.com>2020-07-26 16:22:12 -0700
commit8df4e29cff5e35b00c10c87a9cdfa4044e74edb3 (patch)
treeb9d6b0f9f982ba9c80131f0bb59f1ed1ab507b17 /libs/libv4l
parent3d4bf8cb31b26a46ae85a74c4450ed0415510e3b (diff)
v4l-utils: bring back getsubopt patch
During the update to 1.20.0, this patch was mistakenly removed. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libv4l')
-rw-r--r--libs/libv4l/Makefile2
-rw-r--r--libs/libv4l/patches/030-getsubopt.patch28
2 files changed, 29 insertions, 1 deletions
diff --git a/libs/libv4l/Makefile b/libs/libv4l/Makefile
index 54dfb4368..9755f820d 100644
--- a/libs/libv4l/Makefile
+++ b/libs/libv4l/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=v4l-utils
PKG_VERSION:=1.20.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.linuxtv.org/downloads/v4l-utils
diff --git a/libs/libv4l/patches/030-getsubopt.patch b/libs/libv4l/patches/030-getsubopt.patch
new file mode 100644
index 000000000..3e48732f2
--- /dev/null
+++ b/libs/libv4l/patches/030-getsubopt.patch
@@ -0,0 +1,28 @@
+--- a/utils/v4l2-ctl/v4l2-ctl-common.cpp
++++ b/utils/v4l2-ctl/v4l2-ctl-common.cpp
+@@ -785,15 +785,17 @@ static bool parse_subset(char *optarg)
+
+ static bool parse_next_subopt(char **subs, char **value)
+ {
+- static char *const subopts[] = {
+- NULL
+- };
+- int opt = getsubopt(subs, subopts, value);
++ char *p = *subs;
++ *value = *subs;
+
+- if (opt < 0 || *value)
+- return false;
+- fprintf(stderr, "Missing suboption value\n");
+- return true;
++ while (*p && *p != ',')
++ p++;
++
++ if (*p)
++ *p++ = '\0';
++
++ *subs = p;
++ return false;
+ }
+
+ void common_cmd(const std::string &media_bus_info, int ch, char *optarg)