aboutsummaryrefslogtreecommitdiff
path: root/libs/libv4l
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-11-04 21:27:14 -0700
committerRosen Penev <rosenp@gmail.com>2023-01-17 14:59:04 -0800
commit38c660f48e99f860ec6522949bf980ffc97b9c9c (patch)
tree7c3a42e31fa72d6b9a5c51f99d90e533162fff03 /libs/libv4l
parent8a5ff835dde95e4346cfec7646cc9f2a723565b5 (diff)
libv4l: update to 1.22.1
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libv4l')
-rw-r--r--libs/libv4l/Makefile8
-rw-r--r--libs/libv4l/patches/020-add-missing-includes.patch10
-rw-r--r--libs/libv4l/patches/030-getsubopt.patch28
3 files changed, 3 insertions, 43 deletions
diff --git a/libs/libv4l/Makefile b/libs/libv4l/Makefile
index 60bac1d2b..22b3cd15f 100644
--- a/libs/libv4l/Makefile
+++ b/libs/libv4l/Makefile
@@ -6,17 +6,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=v4l-utils
-PKG_VERSION:=1.20.0
-PKG_RELEASE:=5
+PKG_VERSION:=1.22.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.linuxtv.org/downloads/v4l-utils
-PKG_HASH:=956118713f7ccb405c55c7088a6a2490c32d54300dd9a30d8d5008c28d3726f7
+PKG_HASH:=65c6fbe830a44ca105c443b027182c1b2c9053a91d1e72ad849dfab388b94e31
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_USE_MIPS16:=0
-PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
@@ -75,7 +74,6 @@ define Package/v4l-utils/description
endef
TARGET_CFLAGS += -flto
-TARGET_CXXFLAGS += -std=c++11
TARGET_LDFLAGS += \
$(if $(CONFIG_USE_GLIBC),,-largp) \
-Wl,--gc-sections,--as-needed
diff --git a/libs/libv4l/patches/020-add-missing-includes.patch b/libs/libv4l/patches/020-add-missing-includes.patch
deleted file mode 100644
index c5a83a97a..000000000
--- a/libs/libv4l/patches/020-add-missing-includes.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/utils/libcecutil/cec-info.cpp
-+++ b/utils/libcecutil/cec-info.cpp
-@@ -5,6 +5,7 @@
- * Copyright 2017 Cisco Systems, Inc. and/or its affiliates. All rights reserved.
- */
-
-+#include <cctype>
- #include <stdio.h>
- #include <string>
- #include <unistd.h>
diff --git a/libs/libv4l/patches/030-getsubopt.patch b/libs/libv4l/patches/030-getsubopt.patch
deleted file mode 100644
index 3e48732f2..000000000
--- a/libs/libv4l/patches/030-getsubopt.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/utils/v4l2-ctl/v4l2-ctl-common.cpp
-+++ b/utils/v4l2-ctl/v4l2-ctl-common.cpp
-@@ -785,15 +785,17 @@ static bool parse_subset(char *optarg)
-
- static bool parse_next_subopt(char **subs, char **value)
- {
-- static char *const subopts[] = {
-- NULL
-- };
-- int opt = getsubopt(subs, subopts, value);
-+ char *p = *subs;
-+ *value = *subs;
-
-- if (opt < 0 || *value)
-- return false;
-- fprintf(stderr, "Missing suboption value\n");
-- return true;
-+ while (*p && *p != ',')
-+ p++;
-+
-+ if (*p)
-+ *p++ = '\0';
-+
-+ *subs = p;
-+ return false;
- }
-
- void common_cmd(const std::string &media_bus_info, int ch, char *optarg)