aboutsummaryrefslogtreecommitdiff
path: root/libs/libv4l
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2019-08-21 06:47:33 -0400
committerGitHub <noreply@github.com>2019-08-21 06:47:33 -0400
commit22b0595018ebc9837542979053b521f4aa107f01 (patch)
treea4785400d78a14cd92f8923d52798de98e1ff2cc /libs/libv4l
parent02ad7d814af0a131d96d15e311105510b441aeb8 (diff)
parent67b8da50c16e2ed01e9ae9a311e88b0fb172adc0 (diff)
Merge pull request #9785 from thess/libv4l-update
libv4l: Update to 1.16.6. Fix missing includes patch
Diffstat (limited to 'libs/libv4l')
-rw-r--r--libs/libv4l/Makefile4
-rw-r--r--libs/libv4l/patches/020-add-missing-includes.patch15
-rw-r--r--libs/libv4l/patches/030-getsubopt.patch4
3 files changed, 9 insertions, 14 deletions
diff --git a/libs/libv4l/Makefile b/libs/libv4l/Makefile
index 7b617e63a..a58b8ff01 100644
--- a/libs/libv4l/Makefile
+++ b/libs/libv4l/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=v4l-utils
-PKG_VERSION:=1.16.5
+PKG_VERSION:=1.16.6
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.linuxtv.org/downloads/v4l-utils
-PKG_HASH:=ed80242510385017a1dc566e17a285a77222bb301f5bc19386badfcc2c19df1b
+PKG_HASH:=f9dac1878e3d5636eab7f56bb209fdfc66b94ee8a2aae54dcb4282fe63a678ae
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_LICENSE:=GPL-2.0 LGPL-2.1
diff --git a/libs/libv4l/patches/020-add-missing-includes.patch b/libs/libv4l/patches/020-add-missing-includes.patch
index f1850c82c..695f8e3e0 100644
--- a/libs/libv4l/patches/020-add-missing-includes.patch
+++ b/libs/libv4l/patches/020-add-missing-includes.patch
@@ -20,11 +20,10 @@
#include <linux/cec-funcs.h>
--- a/utils/common/media-info.cpp
+++ b/utils/common/media-info.cpp
-@@ -20,7 +20,7 @@
-
+@@ -21,6 +21,7 @@
#include <linux/media.h>
--#include <fstream>
+ #include <fstream>
+#include <iostream>
#include <media-info.h>
@@ -42,22 +41,20 @@
#include <map>
--- a/utils/v4l2-compliance/media-info.cpp
+++ b/utils/v4l2-compliance/media-info.cpp
-@@ -20,7 +20,7 @@
-
+@@ -21,6 +21,7 @@
#include <linux/media.h>
--#include <fstream>
+ #include <fstream>
+#include <iostream>
#include <media-info.h>
static std::string num2s(unsigned num, bool is_hex = true)
--- a/utils/v4l2-ctl/media-info.cpp
+++ b/utils/v4l2-ctl/media-info.cpp
-@@ -20,7 +20,7 @@
-
+@@ -21,6 +21,7 @@
#include <linux/media.h>
--#include <fstream>
+ #include <fstream>
+#include <iostream>
#include <media-info.h>
diff --git a/libs/libv4l/patches/030-getsubopt.patch b/libs/libv4l/patches/030-getsubopt.patch
index c476e5ed7..5fbb60422 100644
--- a/libs/libv4l/patches/030-getsubopt.patch
+++ b/libs/libv4l/patches/030-getsubopt.patch
@@ -3,11 +3,9 @@ musl libs will set value to NULL which leads to crash.
Simply avoid getsubopt, since we cannot rely on it.
-diff --git a/utils/v4l2-ctl/v4l2-ctl-common.cpp b/utils/v4l2-ctl/v4l2-ctl-common.cpp
-index 3ea6cd3..291fb3e 100644
--- a/utils/v4l2-ctl/v4l2-ctl-common.cpp
+++ b/utils/v4l2-ctl/v4l2-ctl-common.cpp
-@@ -692,16 +692,17 @@ static bool parse_subset(char *optarg)
+@@ -679,16 +679,17 @@ static bool parse_subset(char *optarg)
static bool parse_next_subopt(char **subs, char **value)
{