aboutsummaryrefslogtreecommitdiff
path: root/libs/libuwifi/Makefile
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2019-09-04 17:41:27 +0200
committerNick Hainke <vincent@systemli.org>2019-09-05 00:04:04 +0200
commitba5d69edcda390848416b4cdf805e07fc2787631 (patch)
treed4d86caac3831bc3ab13a48b55590625ab42a986 /libs/libuwifi/Makefile
parent36c8518e7d71ed19ce9a1b2cdbc6d4cac6b413af (diff)
libuwifi: fix dev installation
The ccan needs config.h file. This commit fixes the includes and copies the config.h file to the correct position. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'libs/libuwifi/Makefile')
-rw-r--r--libs/libuwifi/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/libs/libuwifi/Makefile b/libs/libuwifi/Makefile
index c79f84ded..4cb439110 100644
--- a/libs/libuwifi/Makefile
+++ b/libs/libuwifi/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libuwifi
PKG_VERSION:=2019-05-27
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/br101/libuwifi.git
@@ -37,8 +37,12 @@ MAKE_FLAGS += DEBUG=0 LIBNL=tiny BUILD_RADIOTAP=0
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/uwifi
+
$(CP) $(PKG_BUILD_DIR)/include/uwifi/*.h $(1)/usr/include/uwifi
+ $(CP) $(PKG_BUILD_DIR)/linux/*.h $(1)/usr/include/uwifi
+
$(CP) $(PKG_BUILD_DIR)/ccan $(1)/usr/include/
+ $(CP) $(PKG_BUILD_DIR)/config.h $(1)/usr/include/ccan/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/build/libuwifi.{a,so*} $(1)/usr/lib/