aboutsummaryrefslogtreecommitdiff
path: root/libs/libupnp
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-03-23 16:37:50 -0700
committerRosen Penev <rosenp@gmail.com>2020-03-23 16:40:48 -0700
commit8e065c147f7822ca32e053a1da7cc500d0dae2fb (patch)
tree290495f96fc40869f7e6cc5247d9660a6f449c86 /libs/libupnp
parent73b75ed1066d26520a38a0724f388caf6addab52 (diff)
libupnp: enable reuseaddr
Helps applications restart safely. Disabled optssdp. Not used by anything. Disabled scriptsupport. Not used by anything. Made all configure options explicit. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libupnp')
-rw-r--r--libs/libupnp/Makefile21
1 files changed, 20 insertions, 1 deletions
diff --git a/libs/libupnp/Makefile b/libs/libupnp/Makefile
index 39c3e0f1a..d4c23d5ca 100644
--- a/libs/libupnp/Makefile
+++ b/libs/libupnp/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libupnp
PKG_VERSION:=1.8.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/pupnp
@@ -48,6 +48,25 @@ define Package/libupnp-sample/description
TVcontrolpoint & tvdevice sample applications run inside /etc/upnp-tvdevice/
endef
+CONFIGURE_ARGS += \
+ --enable-client \
+ --enable-device \
+ --enable-gena \
+ --enable-reuseaddr \
+ --enable-gena \
+ --enable-webserver \
+ --enable-ssdp \
+ --enable-soap \
+ --enable-tools \
+ --enable-blocking_tcp_connections \
+ --enable-samples \
+ --disable-debug \
+ --disable-optssdp \
+ --disable-unspecified_server \
+ --disable-open_ssl \
+ --disable-scriptsupport \
+ --disable-postwrite
+
TARGET_CFLAGS += -flto
TARGET_LDFLAGS += -flto