aboutsummaryrefslogtreecommitdiff
path: root/libs/libupnp
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2014-07-16 12:31:58 -0400
committerTed Hess <thess@kitschensync.net>2014-07-16 12:31:58 -0400
commit64933e52782888f2cb1e5f8863ad5ba7ac807eba (patch)
tree7496140bded25fc81b6971fafe03420b9bb9f0e6 /libs/libupnp
parentebe93bc90cc18705af8dda43fcb310b98830fb23 (diff)
Import libupnp from oldpackages
Diffstat (limited to 'libs/libupnp')
-rw-r--r--libs/libupnp/Makefile75
1 files changed, 75 insertions, 0 deletions
diff --git a/libs/libupnp/Makefile b/libs/libupnp/Makefile
new file mode 100644
index 000000000..f76f5201f
--- /dev/null
+++ b/libs/libupnp/Makefile
@@ -0,0 +1,75 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libupnp
+PKG_VERSION:=1.6.18
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/pupnp
+PKG_MD5SUM:=11c6484fd2e2927bf3b8d8108407ca56
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libupnp/Default
+ SECTION:=libs
+ CATEGORY:=Libraries
+ URL:=http://pupnp.sourceforge.net/
+endef
+
+define Package/libupnp
+ $(call Package/libupnp/Default)
+ DEPENDS:=+libpthread
+ TITLE:=UPnP SDK library
+ MENU:=1
+endef
+
+define Package/libupnp/description
+The portable SDK for UPnP Devices (libupnp) provides developers with an API and
+open source code for building control points, devices, and bridges that are
+compliant with Version 1.0 of the Universal Plug and Play Device Architecture
+Specification.
+endef
+
+define Package/libupnp-sample
+ $(call Package/libupnp/Default)
+ DEPENDS:=libupnp
+ TITLE:=UPnP sample applications
+endef
+
+define Package/libupnp-sample/description
+TVcontrolpoint & tvdevice sample applications run inside /etc/upnp-tvdevice/
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/upnp $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ixml,threadutil,upnp}.{a,so*,la} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libupnp.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libupnp/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ixml,threadutil,upnp}.so.* $(1)/usr/lib/
+endef
+
+define Package/libupnp-sample/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/upnp/sample/.libs/* $(1)/usr/bin
+ $(INSTALL_DIR) $(1)/etc/upnp-tvdevice/web
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/upnp/sample/web/* $(1)/etc/upnp-tvdevice
+endef
+
+$(eval $(call BuildPackage,libupnp))
+$(eval $(call BuildPackage,libupnp-sample))