aboutsummaryrefslogtreecommitdiff
path: root/libs/libuhttpd
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2023-02-09 11:25:47 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2023-02-16 10:28:52 -0300
commitd0d2f1862bbb4e0780bd73cbe1ae3ba8844521ca (patch)
tree344ac7aa34873eb5efeb5db2e19074c9412f3dfd /libs/libuhttpd
parent51fda9dde7b3a802c7e8d042b35a452e28fea4ca (diff)
libuhttpd: allow building with OpenSSL 3.0
Add -Wno-error=deprecated-declarations to CFLAGS to allow usage of deprecated API. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'libs/libuhttpd')
-rw-r--r--libs/libuhttpd/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/libs/libuhttpd/Makefile b/libs/libuhttpd/Makefile
index 362a0c56e..fabe63b89 100644
--- a/libs/libuhttpd/Makefile
+++ b/libs/libuhttpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libuhttpd
PKG_VERSION:=3.14.1
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL=https://github.com/zhaojh329/libuhttpd/releases/download/v$(PKG_VERSION)
@@ -41,6 +41,7 @@ Package/libuhttpd-mbedtls=$(call Package/libuhttpd/Default,mbedtls,+PACKAGE_libu
Package/libuhttpd-nossl=$(call Package/libuhttpd/Default,nossl)
CMAKE_OPTIONS += -DBUILD_EXAMPLE=OFF
+TARGET_CFLAGS += -Wno-error=deprecated-declarations
ifeq ($(BUILD_VARIANT),openssl)
CMAKE_OPTIONS += -DUSE_OPENSSL=ON