aboutsummaryrefslogtreecommitdiff
path: root/libs/libuecc
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2014-06-12 14:31:48 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2014-06-12 15:12:38 +0200
commiteeb7ac0e60149826bfff36b800bd24aa338737f2 (patch)
tree9431ac6bc83f18597c42c9f4637cbbae6b031b7f /libs/libuecc
parentec23ef3cdc8626a5eaa66cdd3df7c81c0b4c4df9 (diff)
Add libuecc, a very small Elliptic Curve Cryptography library
Diffstat (limited to 'libs/libuecc')
-rw-r--r--libs/libuecc/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/libs/libuecc/Makefile b/libs/libuecc/Makefile
new file mode 100644
index 000000000..0fe483383
--- /dev/null
+++ b/libs/libuecc/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2012-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libuecc
+PKG_VERSION:=4
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=Matthias Schiffer <mschiffer@universe-factory.net>
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://projects.universe-factory.net/attachments/download/71
+PKG_MD5SUM:=7f44df5dc69cb8686947562e2a11eea9
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/libuecc
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Very small Elliptic Curve Cryptography library
+ URL:=http://git.universe-factory.net/libuecc/
+endef
+
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+
+CMAKE_OPTIONS += \
+ -DCMAKE_BUILD_TYPE:String="MINSIZEREL"
+
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/libuecc-$(PKG_VERSION) $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libuecc.a $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libuecc.pc $(1)/usr/lib/pkgconfig/
+endef
+
+$(eval $(call BuildPackage,libuecc))