aboutsummaryrefslogtreecommitdiff
path: root/libs/libuecc
diff options
context:
space:
mode:
authorDominik Menke <dom@digineo.de>2016-12-13 15:42:41 +0100
committerDominik Menke <dom@digineo.de>2016-12-14 10:47:51 +0100
commit8dd99f4f7fd3d7ca5333fba58b709a235919dbb0 (patch)
treeb465bc05cf9d495b92976347126d145585d2721f /libs/libuecc
parent7b812e8fdde595686e49522c46a123346a595631 (diff)
libuecc: use shared instead of static library
This patch prepares for another future package (ecdsautils), which builds multiple binaries all linked to libuecc. The changes are a direct copy of [1]. The original commit message was: > commit cb2ecbfdf0c478568a28aacb99d30fd6ee5c0dd1 > From: Matthias Schiffer <mschiffer@universe-factory.net> > Date: Tue, 3 May 2016 21:33:34 +0200 > Subject: libuecc: use shared instead of static library > > Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> [1]: https://github.com/freifunk-gluon/gluon/blob/cb2ecbfdf0c478568a28aacb99d30fd6ee5c0dd1/patches/packages/openwrt/0007-libuecc-use-shared-instead-of-static-library.patch Signed-off-by: Dominik Menke <dom@digineo.de>
Diffstat (limited to 'libs/libuecc')
-rw-r--r--libs/libuecc/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/libs/libuecc/Makefile b/libs/libuecc/Makefile
index c1ba53f85..811106242 100644
--- a/libs/libuecc/Makefile
+++ b/libs/libuecc/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libuecc
PKG_VERSION:=7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Matthias Schiffer <mschiffer@universe-factory.net>
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -35,11 +35,16 @@ CMAKE_OPTIONS += \
-DCMAKE_BUILD_TYPE:String="MINSIZEREL"
+define Package/libuecc/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libuecc.so* $(1)/usr/lib/
+endef
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/libuecc-$(PKG_VERSION) $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libuecc.a $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libuecc.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libuecc.pc $(1)/usr/lib/pkgconfig/
endef