aboutsummaryrefslogtreecommitdiff
path: root/libs/libtorrent-rasterbar/Makefile
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2022-04-29 10:09:26 +0800
committerRosen Penev <rosenp@gmail.com>2022-04-29 15:25:06 -0700
commit2c78f8b1548d3070839bd1ee6977e25fc55030e6 (patch)
tree54196f704868449c6829f3ce97528a88c2114193 /libs/libtorrent-rasterbar/Makefile
parent3635c768abafb7c9c7b591418abdf0dc30d86c21 (diff)
libtorrent-rasterbar: Update to 2.0.6
Added new dependency "libstdcpp". Removed an upstreamed patch. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'libs/libtorrent-rasterbar/Makefile')
-rw-r--r--libs/libtorrent-rasterbar/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/libs/libtorrent-rasterbar/Makefile b/libs/libtorrent-rasterbar/Makefile
index 12a43979d..c64cec261 100644
--- a/libs/libtorrent-rasterbar/Makefile
+++ b/libs/libtorrent-rasterbar/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libtorrent-rasterbar
-PKG_VERSION:=2.0.5
+PKG_VERSION:=2.0.6
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/arvidn/libtorrent/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=8879d233d81b9bc1b02fdac35f6e1f69509c74da9818c6a819d18b5e42983f56
+PKG_HASH:=75b17d9db3adf0da5896edeaff4db3879f38ee66be953dc9567089db83a070be
PKG_MAINTAINER:=David Yang <mmyangfl@gmail.com>
PKG_LICENSE:=BSD-3-Clause
@@ -24,7 +24,7 @@ define Package/libtorrent-rasterbar
$(call Package/libtorrent-rasterbar/Default)
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+boost-system +libopenssl +libatomic
+ DEPENDS:=+boost-system +libopenssl +libatomic +libstdcpp
endef
#define Package/python3-libtorrent
@@ -47,11 +47,11 @@ endef
#endef
define Download/try_signal
- VERSION:=334fd139e2bb387017b42d36753a03935e3bca75
+ VERSION:=751a7e5a5be14892bcfdff1e63c653bcbf71cf39
SUBDIR:=deps/try_signal
FILE:=$(PKG_NAME)-try_signal-$$(VERSION).tar.xz
URL:=https://github.com/arvidn/try_signal.git
- MIRROR_HASH:=c85d65352c20713cb6cfb005942b46ab7579dc7eef3b876666bff9347149d47f
+ MIRROR_HASH:=32a432e35e81c79f21c49744f00696c112e0deab45d15d91c61ceb63fe25a5f8
PROTO:=git
endef
$(eval $(call Download,try_signal))