aboutsummaryrefslogtreecommitdiff
path: root/libs/libtins
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-06-20 13:25:59 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-06-21 09:52:32 +0800
commit9ac5ac81ab2241b7c13c01e8801e0e7d95ebb4eb (patch)
tree8e917b35332bcae8517d6291258d80f0d44d4b46 /libs/libtins
parent274b111782c1d7650ae244a16e141e39d339af32 (diff)
treewide: avoid deref symlinks when installing .so
This change is inspired by commit openwrt/openwrt@38b22b1e ("nghttp2: deduplicate files in libnghttp2") The packages in this commit are identified with the following command grep -rin -E 'INSTALL_(DATA|BIN)' | grep -F '.so' | grep -F '*' Some of them do not have symlinks and are not affected, but the change is still applied for consideration of best practices just in case Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'libs/libtins')
-rw-r--r--libs/libtins/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/libs/libtins/Makefile b/libs/libtins/Makefile
index 8abc6aa46..66e482bf9 100644
--- a/libs/libtins/Makefile
+++ b/libs/libtins/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libtins
PKG_VERSION:=4.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_MAINTAINER:= Steven Hessing <steven.hessing@gmail.com>
@@ -48,8 +48,8 @@ libtins is a high-level, multiplatform C++ network packet sniffing and crafting
endef
define Package/libtins/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libtins.so.* $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtins.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libtins))