aboutsummaryrefslogtreecommitdiff
path: root/libs/libtins/Makefile
diff options
context:
space:
mode:
authorIlya Tsybulsky <ilya.tsybulsky@gmail.com>2020-02-09 22:48:43 +0300
committerIlya Tsybulsky <ilya.tsybulsky@gmail.com>2020-02-10 00:48:35 +0300
commitb93136bdeac05e75731cc5a39cbbfa3056ae3d10 (patch)
tree488524c8a5699152f44f6fd47b471dbebf86caed /libs/libtins/Makefile
parentfed1b3b11bf9361dbbd158a1018c701d8180e49b (diff)
libtins: Added menu configuration options
Signed-off-by: Ilya Tsybulsky <ilya.tsybulsky@gmail.com>
Diffstat (limited to 'libs/libtins/Makefile')
-rw-r--r--libs/libtins/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/libs/libtins/Makefile b/libs/libtins/Makefile
index 318da36fa..10d1acacc 100644
--- a/libs/libtins/Makefile
+++ b/libs/libtins/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libtins
PKG_VERSION:=4.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/mfontanini/libtins/tar.gz/v$(PKG_VERSION)?
@@ -30,7 +30,12 @@ define Package/libtins
CATEGORY:=Libraries
TITLE:=libtins
URL:=https://libtins.github.io/
- DEPENDS:=+libstdcpp +libpcap
+ DEPENDS:=+libstdcpp +LIBTINS_ENABLE_PCAP:libpcap +LIBTINS_ENABLE_WPA2:libopenssl
+ MENU:=1
+endef
+
+define Package/libtins/config
+ source "$(SOURCE)/Config.in"
endef
define Package/libtins/description
@@ -41,12 +46,12 @@ CMAKE_OPTIONS += \
-D_RUN_RESULT_VAR=FORCE \
-DLIBTINS_BUILD_EXAMPLES=OFF \
-DLIBTINS_BUILD_TESTS=OFF \
- -DLIBTINS_ENABLE_ACK_TRACKER=OFF \
- -DLIBTINS_ENABLE_CXX11=ON \
- -DLIBTINS_ENABLE_DOT11=OFF \
- -DLIBTINS_ENABLE_PCAP=ON \
- -DLIBTINS_ENABLE_TCP_STREAM_CUSTOM_DATA=OFF \
- -DLIBTINS_ENABLE_WPA2=OFF
+ -DLIBTINS_ENABLE_ACK_TRACKER=$(if $(CONFIG_LIBTINS_ENABLE_ACK_TRACKER),ON,OFF) \
+ -DLIBTINS_ENABLE_CXX11=$(if $(CONFIG_LIBTINS_ENABLE_CXX11),ON,OFF) \
+ -DLIBTINS_ENABLE_DOT11=$(if $(CONFIG_LIBTINS_ENABLE_DOT11),ON,OFF) \
+ -DLIBTINS_ENABLE_PCAP=$(if $(CONFIG_LIBTINS_ENABLE_PCAP),ON,OFF) \
+ -DLIBTINS_ENABLE_TCP_STREAM_CUSTOM_DATA=$(if $(CONFIG_LIBTINS_ENABLE_TCP_STREAM_CUSTOM_DATA),ON,OFF) \
+ -DLIBTINS_ENABLE_WPA2=$(if $(CONFIG_LIBTINS_ENABLE_WPA2),ON,OFF)
TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed