aboutsummaryrefslogtreecommitdiff
path: root/libs/libssh
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-03-04 14:45:01 -0800
committerRosen Penev <rosenp@gmail.com>2021-03-27 21:51:50 -0700
commita31b7320077c340268d31642ded69cc66fbc230c (patch)
tree884808c8657f774a56f82720486b88017f30e6a6 /libs/libssh
parent3ad92293da92b2d5fc3de1ccc214a69f2b081f2e (diff)
treewide: build CMake projects with Ninja
faster to compile. A small selection of packages was tested going from: Executed in 696.30 secs fish external usr time 82.98 mins 395.00 micros 82.98 mins sys time 9.02 mins 0.00 micros 9.02 mins to: Executed in 592.20 secs fish external usr time 84.84 mins 361.00 micros 84.84 mins sys time 8.85 mins 57.00 micros 8.85 mins Tested by running make -j 12 and wiping staging/build_dir/target_x Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libssh')
-rw-r--r--libs/libssh/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/libs/libssh/Makefile b/libs/libssh/Makefile
index d747bfa2d..fa05b920b 100644
--- a/libs/libssh/Makefile
+++ b/libs/libssh/Makefile
@@ -22,11 +22,10 @@ PKG_CPE_ID:=cpe:/a:libssh:libssh
CMAKE_INSTALL:=1
CMAKE_BINARY_SUBDIR:=build
-PKG_BUILD_PARALLEL:=1
PKG_USE_MIPS16:=0
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
+include ../../devel/ninja/ninja-cmake.mk
define Package/libssh
SECTION:=libs
@@ -41,7 +40,7 @@ define Package/libssh/description
for client and server implementations.
endef
-CMAKE_OPTIONS = \
+CMAKE_OPTIONS += \
-DHAVE_STRTOULL=1 \
-DHAVE_GETADDRINFO=1 \
-DHAVE_TERMIOS_H=1 \