aboutsummaryrefslogtreecommitdiff
path: root/libs/libssh2
diff options
context:
space:
mode:
authorJiri Slachta <slachta@cesnet.cz>2014-07-17 22:27:24 +0200
committerJiri Slachta <slachta@cesnet.cz>2014-07-17 22:27:24 +0200
commitbc4713cb7c2c22f08f93c37be2e45c2b97fe92cb (patch)
tree12e275130de45fbda6d7a6ac50b1b707aac24ac9 /libs/libssh2
parentfa3a6a81d1c4c644108fed2d461d4566e3362f8f (diff)
libssh2: import from oldpackages, add myself as maintainer
Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
Diffstat (limited to 'libs/libssh2')
-rw-r--r--libs/libssh2/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/libs/libssh2/Makefile b/libs/libssh2/Makefile
new file mode 100644
index 000000000..5ab4f1871
--- /dev/null
+++ b/libs/libssh2/Makefile
@@ -0,0 +1,55 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libssh2
+PKG_VERSION:=1.4.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.libssh2.org/download
+PKG_MD5SUM:=071004c60c5d6f90354ad1b701013a0b
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libssh2
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=SSH2 library
+ URL:=http://www.libssh2.org/
+ DEPENDS:=+libopenssl +zlib
+ MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
+endef
+
+define Package/libssh2/description
+ libssh2 is a client-side C library implementing the SSH2 protocol.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --disable-examples-build \
+ --with-libssl-prefix=$(STAGING_DIR)/usr
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libssh2.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libssh2.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libssh2/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libssh2.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libssh2))