aboutsummaryrefslogtreecommitdiff
path: root/libs/libssh2
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2018-02-03 13:26:16 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2018-02-03 13:26:18 +0100
commit6b3f140c0c357dd8a6fedb032d296f129abf3a94 (patch)
treeeb81ba600bc12db22d0fd28cd79d2ac0e419f4ec /libs/libssh2
parentf85ffb54f16e04b211b76e03ae29aa3ed96b9365 (diff)
libssh2: Make crypto backends selectable
This adds a choice to menuselect so people can select if they would like to compile libssh2 against mbedtls (default) or openssl. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs/libssh2')
-rw-r--r--libs/libssh2/Config.in15
-rw-r--r--libs/libssh2/Makefile10
2 files changed, 22 insertions, 3 deletions
diff --git a/libs/libssh2/Config.in b/libs/libssh2/Config.in
new file mode 100644
index 000000000..708c07bad
--- /dev/null
+++ b/libs/libssh2/Config.in
@@ -0,0 +1,15 @@
+if PACKAGE_libssh2
+
+choice
+ prompt "Choose crypto backend"
+ default LIBSSH2_MBEDTLS
+
+ config LIBSSH2_MBEDTLS
+ bool "mbedtls"
+
+ config LIBSSH2_OPENSSL
+ bool "openssl"
+
+endchoice
+
+endif
diff --git a/libs/libssh2/Makefile b/libs/libssh2/Makefile
index e996dfadf..cdb133cb5 100644
--- a/libs/libssh2/Makefile
+++ b/libs/libssh2/Makefile
@@ -29,7 +29,7 @@ define Package/libssh2
CATEGORY:=Libraries
TITLE:=SSH2 library
URL:=https://www.libssh2.org/
- DEPENDS:=+libmbedtls +zlib
+ DEPENDS:=+LIBSSH2_MBEDTLS:libmbedtls +LIBSSH2_OPENSSL:libopenssl +zlib
MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
endef
@@ -37,13 +37,17 @@ define Package/libssh2/description
libssh2 is a client-side C library implementing the SSH2 protocol.
endef
+define Package/libssh2/config
+ source "$(SOURCE)/Config.in"
+endef
+
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--disable-examples-build \
--disable-silent-rules \
- --with-mbedtls \
- --with-libmbedtls-prefix=$(STAGING_DIR)/usr \
+ $(if $(CONFIG_LIBSSH2_MBEDTLS),--with-mbedtls --with-libmbedtls-prefix=$(STAGING_DIR)/usr) \
+ $(if $(CONFIG_LIBSSH2_OPENSSL),--with-openssl --with-libssl-prefix=$(STAGING_DIR)/usr) \
--with-libz-prefix=$(STAGING_DIR)/usr
define Build/InstallDev