aboutsummaryrefslogtreecommitdiff
path: root/libs/libssh2
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-08-28 13:01:34 -0700
committerRosen Penev <rosenp@gmail.com>2019-08-28 13:07:34 -0700
commit6a1cd83265209ea882d9b2c71543257273d3d834 (patch)
treeff1b313c6f24c3795aab8d2ce96dd54f5046bad5 /libs/libssh2
parenta447e1c6b2dac374bbd8b84554d994628f897453 (diff)
libssh2: Remove old artifacts from autotools platform
Removed PKG_FIXUP. It has no meaning with CMake. Replaced PKG_INSTALL with CMAKE_INSTALL. Consequentially, removed InstallDev section. Added ABI_VERSION to force package rebuilds when it increases. Added PKG_BUILD_PARALLEL for faster compilation. Fixed license tag. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libssh2')
-rw-r--r--libs/libssh2/Makefile23
1 files changed, 7 insertions, 16 deletions
diff --git a/libs/libssh2/Makefile b/libs/libssh2/Makefile
index 765ae38e2..f619f37ee 100644
--- a/libs/libssh2/Makefile
+++ b/libs/libssh2/Makefile
@@ -15,14 +15,14 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.libssh2.org/download
PKG_HASH:=d5fb8bd563305fd1074dda90bd053fb2d29fc4bce048d182f96eaa466dfadafd
-PKG_FIXUP:=autoreconf
-
-PKG_INSTALL:=1
-
-PKG_LICENSE:=BSD
+PKG_MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
+PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:libssh2:libssh2
+CMAKE_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
PKG_CONFIG_DEPENDS:= \
CONFIG_LIBSSH2_MBEDTLS \
CONFIG_LIBSSH2_OPENSSL
@@ -36,7 +36,7 @@ define Package/libssh2
TITLE:=SSH2 library
URL:=https://www.libssh2.org/
DEPENDS:=+LIBSSH2_MBEDTLS:libmbedtls +LIBSSH2_OPENSSL:libopenssl +zlib
- MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
+ ABI_VERSION:=1
endef
define Package/libssh2/description
@@ -59,18 +59,9 @@ else
CMAKE_OPTIONS += -DCRYPTO_BACKEND=mbedTLS
endif
-define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/include
- $(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libssh2.so* $(1)/usr/lib/
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libssh2.pc $(1)/usr/lib/pkgconfig/
-endef
-
define Package/libssh2/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libssh2.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libssh2.so.$(ABI_VERSION)* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libssh2))