aboutsummaryrefslogtreecommitdiff
path: root/libs/libssh2
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2018-03-03 09:16:46 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2018-03-03 09:19:29 +0100
commit27c77ff0e95a2a129f55a161df8ac5fb4fe5f179 (patch)
tree86b44e1c84be253694353389aa9f7d0b2789a792 /libs/libssh2
parent0a8bdb8564d456d1192cf64458f85fba3f51e632 (diff)
libssh2: add missing PKG_CONFIG_DEPENDS
Recently added symbols CONFIG_LIBSSH2_MBEDTLS and CONFIG_LIBSSH2_OPENSSL require a rerun of ./configure when their selection changes. So add them to PKG_CONFIG_DEPENDS accordingly. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs/libssh2')
-rw-r--r--libs/libssh2/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/libs/libssh2/Makefile b/libs/libssh2/Makefile
index d593c264b..926c010c9 100644
--- a/libs/libssh2/Makefile
+++ b/libs/libssh2/Makefile
@@ -22,6 +22,10 @@ PKG_INSTALL:=1
PKG_LICENSE:=BSD
PKG_LICENSE_FILES:=COPYING
+PKG_CONFIG_DEPENDS:= \
+ CONFIG_LIBSSH2_MBEDTLS \
+ CONFIG_LIBSSH2_OPENSSL
+
include $(INCLUDE_DIR)/package.mk
define Package/libssh2