aboutsummaryrefslogtreecommitdiff
path: root/libs/libsocketcan/Makefile
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2023-11-22 09:15:34 +0100
committerRosen Penev <rosenp@gmail.com>2023-12-01 11:27:16 -0800
commit26046a3261749a461577c501ab70af86d131867b (patch)
treea4b07be5fbc4c592137ad560e350cf553471e463 /libs/libsocketcan/Makefile
parente2573ca13f710c90f70d599f15b941dd54abf1d5 (diff)
libsocketcan: new package
Readd and update the libsocketcan package from OpenWrt 14.07: https://git.archive.openwrt.org/?p=14.07/packages.git;a=blob;f=libs/libsocketcan/Makefile;hb=a2d1927140548a805970f0859150556ea0b22a78 Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Diffstat (limited to 'libs/libsocketcan/Makefile')
-rw-r--r--libs/libsocketcan/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/libs/libsocketcan/Makefile b/libs/libsocketcan/Makefile
new file mode 100644
index 000000000..158923234
--- /dev/null
+++ b/libs/libsocketcan/Makefile
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libsocketcan
+PKG_VERSION:=0.0.12
+PKG_RELEASE=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://www.pengutronix.de/software/libsocketcan/download/
+PKG_HASH:=be8280124707701935e6294d366e2474158b758fa4b2e3cae571d5b256d2fe34
+
+PKG_MAINTAINER:=Yegor Yefremov <yegorslists@googlemail.com>
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libsocketcan
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Library to control SocketCAN interfaces
+ URL:=https://git.pengutronix.de/cgit/tools/libsocketcan
+endef
+
+define Package/libsocketcan/description
+ This userspace library allows one to do common configure/control tasks
+on a SocketCAN interface.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/can_netlink.h $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/libsocketcan.h $(1)/usr/include
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsocketcan.{a,so*} $(1)/usr/lib
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libsocketcan.pc $(1)/usr/lib/pkgconfig
+endef
+
+define Package/libsocketcan/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsocketcan.so* $(1)/usr/lib
+endef
+
+$(eval $(call BuildPackage,libsocketcan))