aboutsummaryrefslogtreecommitdiff
path: root/libs/libsoc
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2018-07-05 09:56:04 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2018-07-09 11:33:55 +0800
commit19bde8da683bfee543b3815d0614e7bf900acda3 (patch)
tree91a24a61399d1edcd1bfcfcad2c4fa9d432d01eb /libs/libsoc
parent21bef99c742d3fec236d1fd322edb6b7e5300055 (diff)
libsoc: fix compilation error caused by multiple goals on make
Error of the following kind can happen when parallel build with goals "all" and "install" both specified on the command line. Seems like make can parallelly build for both targets causing race conditions make[3]: Entering directory `/tmp/tmp.HIR3tEIqBb/build_dir/target-mips_24kc_musl/libsoc-2016-12-22-5b788d4d' Making all in lib Making install in lib make[4]: Entering directory `/tmp/tmp.HIR3tEIqBb/build_dir/target-mips_24kc_musl/libsoc-2016-12-22-5b788d4d/lib' CC libsoc_la-gpio.lo make[4]: Entering directory `/tmp/tmp.HIR3tEIqBb/build_dir/target-mips_24kc_musl/libsoc-2016-12-22-5b788d4d/lib' CC libsoc_la-spi.lo CC libsoc_la-gpio.lo CC libsoc_la-file.lo CC libsoc_la-i2c.lo CC libsoc_la-spi.lo CC libsoc_la-pwm.lo CC libsoc_la-board.lo CC libsoc_la-file.lo CC libsoc_la-conffile.lo CC libsoc_la-debug.lo CC libsoc_la-pwm.lo CC libsoc_la-conffile.lo CCLD libsoc.la OpenWrt-libtool: link: `libsoc_la-pwm.lo' is not a valid libtool object make[4]: *** [libsoc.la] Error 1 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'libs/libsoc')
-rw-r--r--libs/libsoc/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/libs/libsoc/Makefile b/libs/libsoc/Makefile
index 8209960b9..c733a5811 100644
--- a/libs/libsoc/Makefile
+++ b/libs/libsoc/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libsoc
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/jackmitch/libsoc.git
@@ -43,11 +43,6 @@ CONFIGURE_ARGS += \
--enable-static \
--disable-cxx
-MAKE_FLAGS += \
- CFLAGS="$(TARGET_CFLAGS)" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/libsoc_board.h $(1)/usr/include/