aboutsummaryrefslogtreecommitdiff
path: root/libs/libshout
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-02-17 06:51:02 +0100
committerNicolas Thill <nico@openwrt.org>2015-02-17 06:51:02 +0100
commitdd17d21b2f1fd51778d2664def498ebd6df01f13 (patch)
tree2f252873211c07b06dc82783ab452b1d3b435a7c /libs/libshout
parent548c85a5f94883c08b630ae8c6236d563f10bcb7 (diff)
libshout: import from old packages feed
- add license info - add myself as maintainer Signed-off-by: Nicolas Thill <nico@openwrt.org>
Diffstat (limited to 'libs/libshout')
-rw-r--r--libs/libshout/Makefile68
-rw-r--r--libs/libshout/patches/120-vorbis-c.patch11
-rw-r--r--libs/libshout/patches/140-no_example_doc_win32.patch17
3 files changed, 96 insertions, 0 deletions
diff --git a/libs/libshout/Makefile b/libs/libshout/Makefile
new file mode 100644
index 000000000..ee96b17f3
--- /dev/null
+++ b/libs/libshout/Makefile
@@ -0,0 +1,68 @@
+#
+# Copyright (C) 2008-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libshout
+PKG_VERSION:=2.3.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/libshout/
+PKG_MD5SUM:=11765b2592e7ea623ccd93d3f8df172c
+
+PKG_LICENSE:=LGPL-2.0+
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libshout
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Library which can be used to write a source client like ices
+ URL:=http://www.icecast.org/download.php
+ DEPENDS:= +libspeex +libtheora +libvorbis +libvorbisidec +libpthread
+endef
+
+define Package/libshout/description
+ libshout allows applications to easily communicate and broadcast
+ to an Icecast streaming media server. It handles the socket connections,
+ metadata communication, and data streaming for the calling application,
+ and lets developers focus on feature sets instead of implementation
+ details.
+endef
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+
+CONFIGURE_VARS += \
+ VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/" \
+ VORBIS_LIBS="$(TARGET_LDFLAGS) -lvorbis -lvorbisidec" \
+
+TARGET_CFLAGS += $(FPIC) -Wl,-rpath-link="$(STAGING_DIR)/usr/lib"
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/shout $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libshout.{a,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/shout.pc $(1)/usr/lib/pkgconfig/
+ $(SED) 's| -I/usr/include||' $(1)/usr/lib/pkgconfig/shout.pc
+endef
+
+define Package/libshout/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libshout.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libshout))
diff --git a/libs/libshout/patches/120-vorbis-c.patch b/libs/libshout/patches/120-vorbis-c.patch
new file mode 100644
index 000000000..a9e41f93a
--- /dev/null
+++ b/libs/libshout/patches/120-vorbis-c.patch
@@ -0,0 +1,11 @@
+--- a/src/vorbis.c
++++ b/src/vorbis.c
+@@ -28,7 +28,7 @@
+ #endif
+ #include <stdlib.h>
+
+-#include <vorbis/codec.h>
++#include <tremor/ivorbiscodec.h>
+
+ #include "shout_private.h"
+ #include "shout_ogg.h"
diff --git a/libs/libshout/patches/140-no_example_doc_win32.patch b/libs/libshout/patches/140-no_example_doc_win32.patch
new file mode 100644
index 000000000..9e8b5a357
--- /dev/null
+++ b/libs/libshout/patches/140-no_example_doc_win32.patch
@@ -0,0 +1,17 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -288,12 +288,12 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AUTOMAKE_OPTIONS = 1.6 foreign
+ ACLOCAL_AMFLAGS = -I m4
+-SUBDIRS = include src examples debian doc win32
++SUBDIRS = include src debian
+ EXTRA_DIST = INSTALL m4/shout.m4 m4/acx_pthread.m4 \
+ m4/ogg.m4 m4/vorbis.m4 m4/xiph_compiler.m4 m4/xiph_net.m4 \
+ m4/xiph_types.m4
+
+-doc_DATA = COPYING NEWS README examples/example.c examples/nonblocking.c
++doc_DATA = COPYING NEWS README
+ m4datadir = $(datadir)/aclocal
+ m4data_DATA = m4/shout.m4
+ @HAVE_PKGCONFIG_TRUE@pkgconfigdir = $(libdir)/pkgconfig